Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on Dec 8, 2022, between 7 am & 7 pm EST, in the DOTS Dev Blitz Day 2022 - Q&A forum, Discord, and Unity3D Subreddit to learn more about DOTS directly from the Unity Developers.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

[Bug] [Will never be adressed] Access denied

Discussion in 'Meta-forum Discussion' started by APSchmidt, Nov 3, 2021.

  1. Deleted User

    Deleted User

    Guest

    I use Chrome, up-to-date.
     
  2. APSchmidt

    APSchmidt

    Joined:
    Aug 8, 2016
    Posts:
    4,318
    Happened today again:

    Reference #18.98e24817.1651387689.3054cc43

    It's not because I'm the only one reporting this that I'm the only one experiencing it. :)

    I'm using Firefox 99.0.1 (64 bits) on Linux Mint, up to date. I use private windows only which means that cookies, history and the rest are deleted each time I close it. I also refuse all the cookies when I connect here.

    And you are the only site that gives me problems (well, not the only one but the other is not a big one like yours). I suspect that the problem is related to me refusing the cookies, your partners might not like that at all.

    Sorry but it's not for us to find a workaround; thanks for the info though maybe others will want to use it. :)
     
    nasos_333 likes this.
  3. APSchmidt

    APSchmidt

    Joined:
    Aug 8, 2016
    Posts:
    4,318
    Today again: Reference #18.88a51002.1651815343.1a2e8c6
     
    nasos_333 likes this.
  4. APSchmidt

    APSchmidt

    Joined:
    Aug 8, 2016
    Posts:
    4,318
    Okay, I get it, this will never be fixed.

    Today's reference: Reference #18.c4e24817.1651905878.dacd61
     
    nasos_333 likes this.
  5. Deleted User

    Deleted User

    Guest

    I hope you like it, Unity:

    Screenshot 2022-05-19 174329.png

    I got re-access by applying my workaround.​
     
  6. nasos_333

    nasos_333

    Joined:
    Feb 13, 2013
    Posts:
    11,619
    bump, still happening these days

    Happens in my desktop, all browsers i tried (Opera, Chrome)

    Does not happen on my mobile, so i can check forum normally there
     
  7. nasos_333

    nasos_333

    Joined:
    Feb 13, 2013
    Posts:
    11,619
    Update: It seems to happen randomly, also happens in mobile now

    Please fix, as is impossible to visit the forums normally
     
  8. khos

    khos

    Joined:
    May 10, 2016
    Posts:
    1,252
    What is going on at Unity?! Why do partners control their sites? I guess cost related... with service clearly impacted, seems like a bad service.
     
    nasos_333 likes this.
  9. khos

    khos

    Joined:
    May 10, 2016
    Posts:
    1,252
    If I see the error I refresh a few times and then the page loads, just some info to share
     
    nasos_333 likes this.
  10. nasos_333

    nasos_333

    Joined:
    Feb 13, 2013
    Posts:
    11,619
    Hi, the issue is still happening and with much larger frequency than before.



    It fixes itself after few minutes, then happens again, but renders the forums rather unusable at this point

    It happens in every browser and platform, i think is related to the load of data a user accesses, e.g. if i dont open any thread can browse more time without see the issue, if open many heavy in images threads then get the error for sure directly.

    So i think is just a stopper of drawing too much data from the company handling your traffic

    Hope this helps

    Note that forums lately are unusable due to this issue, i get constantly the problem and blocks me for many minutes, which means cant also provide asset support and do proper discussion in threads etc

    This is by far and away the most critical thing currently and should be the no1 priority to fix

    Thanks in advance
     
    Last edited: Aug 6, 2022
  11. khos

    khos

    Joined:
    May 10, 2016
    Posts:
    1,252
    I am not seeing this anymore, weird, maybe something is fixed?
     
  12. nasos_333

    nasos_333

    Joined:
    Feb 13, 2013
    Posts:
    11,619


    I get it instantly when open any thread with many images, happens every time too.

    E.g. this thread i tested just now

    https://forum.unity.com/threads/upg...ender-cartoon-shaders-image-fx-tools.1275767/

    Or this one

    https://forum.unity.com/threads/new...meshes-work-on-mobile-hdrp-urp.351694/page-34

    Or this

    https://forum.unity.com/threads/big...er-next-generation-ocean-system.767168/page-2

    I think is just a bandwidth based limiter with a timer, seems clear now after few tries with image heavy threads.
     
  13. nasos_333

    nasos_333

    Joined:
    Feb 13, 2013
    Posts:
    11,619
    Has been 5 months now and the issue is still there and increasing in frequency making the forums unusable.

    Imo is now best idea to change partners, than try to fix a broken backend, which apparently is not possible.

    Hopefully this will be resolved soon :(

    Hi,

    Is there any update on this ?

    We try to offer support for assets in the forum and is nearly impossible now, this error happens constantly and at an increasing rate.

    It is very critical to be fixed the soonest, as the forums are not usuable.

    It happens every single time in every browser and platform, when load a heavy in images thread.

    Thanks
     
    Last edited: Aug 10, 2022
  14. Rowlan

    Rowlan

    Joined:
    Aug 4, 2016
    Posts:
    3,123
    I did some more testing since I had it as well. It's not that much of an issue since it affects only individual users, not the whole user base.

    In short, an example link:

    https://forum.unity.com/threads/what-is-on-secret-sale-2nd-new-thread.1191568/page-20

    Once you visit that one, something happens and your IP gets banned (or whatever weird dark magic happens in the background). You get Access Denied for like 10 minutes, after that you can access the forum again.

    The Access Denied seems to be IP based, I tried with different browsers (firefox, chrome, edge) on my PC. All on the same PC had the same Access Denied issue, even ones where I wasn't logged in. So it's not a cookie or browser thing. When I tried on my Phone which was going over the same WIFI the same issue occurred. When I disabled WIFI on the Phone and used paid data tariff the forum worked as usual.
     
    mgear likes this.
  15. mgear

    mgear

    Joined:
    Aug 3, 2010
    Posts:
    8,113
    interesting, tested and it happens..

    i'm guessing it could be related to all those images on that thread,
    so browser makes hundreds of requests into unity server?

    i've noticed it sometimes happens to me, if i open tens of new tabs, for checking message alerts..
    that would match to some kind of request spam issue.

    *tested: Disable image loading from browser, no ban if visit that link.
     
    Last edited: Aug 11, 2022
    Rowlan likes this.
  16. Rowlan

    Rowlan

    Joined:
    Aug 4, 2016
    Posts:
    3,123
    I can confirm that, same for me. Those images are very small and have low bandwidth. But maybe it's indeed the sum of async requests of them. Definitely reproducible and solvable by a Unity forum dev.
     
    nasos_333 likes this.
  17. orionsyndrome

    orionsyndrome

    Joined:
    May 4, 2014
    Posts:
    2,173
    Honestly, this sounds like the forum devs have implemented a poor solution to react to a naively detected DDoS. Basically, if the database throttles down (or pings too many 3rd party servers) they introduce a deliberate time-out bottleneck, similar to how TCP-IP was designed to reroute traffic and prevent complete system halt. Now I'm not saying that Unity's hardware is at fault (seriously this is all scalable and they're probably just renting it out flat), but this might be a compounding issue, where something else entirely in the forum code ecosystem produces a domino effect and the stresses precipitate to the point of having an overall effect, but without a reasonable cause. Given how horrible these web technologies really are, perhaps there is no one really who knows what's wrong or how to fix it.
     
    Antypodish likes this.
  18. Rowlan

    Rowlan

    Joined:
    Aug 4, 2016
    Posts:
    3,123
    @UnityMaru maybe from the info above it's just some setting that creates a false positive of a DoS attack and that threshold just needs to be set a tad higher.
     
  19. mgear

    mgear

    Joined:
    Aug 3, 2010
    Posts:
    8,113
    i've also reported it that day, got reply that its forwarded to people handling the forum or something..
     
  20. nasos_333

    nasos_333

    Joined:
    Feb 13, 2013
    Posts:
    11,619
    The forum is completely useless at this point, every time i open a thread may lock out for many minutes, looks like a practical joke at this point.

    What is the purpose of having a forum if is not working at all ?

    This was never an issue before, so i assume a few months back something changed that made this mess.

    Please fix this as it is impossible to do anything with the forum anymore.
     
  21. nasos_333

    nasos_333

    Joined:
    Feb 13, 2013
    Posts:
    11,619
    Hi, is there any update on this ?

    It has only got worse and make the forum unusable, thanks
     
  22. mgear

    mgear

    Joined:
    Aug 3, 2010
    Posts:
    8,113
    Last edited: Aug 23, 2022
    orionsyndrome, nasos_333 and Rowlan like this.
  23. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    3,021
    Hi everyone,

    Apologies for the long wait. We had escalated the reports in this thread that continued to come in after the initial fix was deployed but the team was unable to isolate the issue based on the available information at the time. We should have closed the loop with you and provided an update together with follow-up questions so I'd like to apologize for missing out on that, too.

    Based on the reproduction steps provided by @Rowlan, I have asked to restart the investigation process again. Thank you very much for bringing these findings to the thread.

    We will update you once we have more information to share. Thank you for bearing with us.
     
    UnityJuju and Rowlan like this.
  24. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    3,021
    Hi everyone,

    We've deployed some changes to help with these issues. If you continue to experience the same types of errors, please let us know.
     
    Asset_Street_221B and Rowlan like this.