Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Unity Stuck on loading logo after install on Ubuntu

Discussion in 'Linux' started by adhulkrishna, Sep 28, 2022.

  1. adhulkrishna


    Feb 22, 2021
    I was going to develop game from linux in unity i installed unity from the instruction from their website

    but i ran into an error known as
    Error: chmod: cannot access '/opt/unityhub/chrome-sandbox': No such file or directory

    here is what i get from terminal

    sudo apt install unityhub
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    The following NEW packages will be installed:
    0 upgraded, 1 newly installed, 0 to remove and 14 not upgraded.
    Need to get 0 B/131 MB of archives.
    After this operation, 407 MB of additional disk space will be used.
    Selecting previously unselected package unityhub.
    (Reading database ... 234390 files and directories currently installed.)
    Preparing to unpack .../unityhub_3.3.0_amd64.deb ...
    Unpacking unityhub (3.3.0) ...
    Setting up unityhub (3.3.0) ...
    chmod: cannot access '/opt/unityhub/chrome-sandbox': No such file or directory
    Processing triggers for bamfdaemon (0.5.6+22.04.20220217-0ubuntu1) ...
    Rebuilding /usr/share/applications/bamf-2.index...
    Processing triggers for desktop-file-utils (0.26-1ubuntu3) ...
    Processing triggers for hicolor-icon-theme (0.17-2) ...
    Processing triggers for gnome-menus (3.36.0-1ubuntu3) ...
    Processing triggers for mailcap (3.70+nmu1ubuntu1) ...

  2. yangqihan1999


    Feb 9, 2020
    Hey I got the same problem. Have you solved it? Thanks.
  3. tylerinthezoo


    Unity Technologies

    Jun 15, 2022
  4. hifron_ax


    Sep 13, 2023
    Seems as some openssl1.1 issue(could be downloaded and dpkg -i installed or compiled) or chromium transition to snap, but Unity uses also C# and Licensing requires that.

    But also if running unityhub fails, there is still option to run Editor/version(default link missing to scripting needs :)/Unity and then unityhub runs and also Unity Editor, but simply there is some fix needed. If there is unofficial AppImage, then it needs to be made official because who know what version it is or if some debugging bug S***s it contains.

    But on other apps with chrome-sandbox in the directory with sandbox in app enabled( I get:
    The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /home/user/.itch/app-version/chrome-sandbox is owned by root and has mode 4755

    some apps(which uses chrome with sandbox) could be run as
    chrome --no-sandbox
    at start, but seems as this new Ubuntu feature with Unprivileged user namespaces going forward will be restricted
    Last edited: May 3, 2024