Search Unity

  1. We've closed the job boards. If you're looking for work, or looking to hire check out Unity Connect. You can see more information here.
    Dismiss Notice
  2. We're running great holiday deals on subscriptions, swag and Asset Store packages! Take a peek at this blog for more information!
    Dismiss Notice
  3. Check out our Unite Austin 2017 YouTube playlist to catch up on what you missed. More videos coming soon.
    Dismiss Notice
  4. Unity 2017.2 is now released.
    Dismiss Notice
  5. The Unity Gear Store is here to help you look great at your next meetup, user group or conference. With all new Unity apparel, stickers and more!
    Dismiss Notice
  6. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  7. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice
  8. Unity 2017.3 beta is now available for download.
    Dismiss Notice

Ultimate Water System - The most advanced realtime water simulation

Discussion in 'Assets and Asset Store' started by Moonlit-Games-Studio, Sep 7, 2017.

  1. SquadraCorse

    SquadraCorse

    Joined:
    May 28, 2014
    Posts:
    7
    I just upgraded from PlayWay and have two questions about Ultimate Water. Any help would be very much appreciated.

    First, I was wondering if a shoreline demo was in the works? I was using the shore profile and wave emitter in the PlayWay beta and was hoping there would be something similar in Ultimate Water.

    Second, I am using Enviro for my sky/weather system. I noticed that when the sky is completely overcast, the water still reflects the sun/direct-light. I turned off every reflection I could find (disabled planar, no SSRR, etc.) but the only way I found to get rid of this was to disable the direct light or mask off the water. Should I report this on the GitHub repository, or am I just missing something?

    PS - Here's a pic of that reflection:
    UW_ReflectingSunBlockedClouds_02.jpg
     
  2. Moonlit-Games-Studio

    Moonlit-Games-Studio

    Joined:
    Feb 11, 2014
    Posts:
    20
    We had to move UWS to account with PlayWay Water System: https://www.assetstore.unity3d.com/
    Please send us your invoice number to receive free coupon allowing you to purchase UWS on current account.
    Sorry for the inconvenience.

    Thanks! We really hope that you wont be disappointed this time :)
     
  3. MCPGNZ

    MCPGNZ

    Joined:
    Sep 29, 2016
    Posts:
    27
    I'd like to inform you that I'm in the progress of solving the submitted issues (as well as some other, PM'd to me).
    I've also merged the bug-fixes from the PW2.0b13 (i.a. problems with Planar Reflections on AMD cards) and i hope to release new hot-fix batch at the end of this week.

    @Aquaminator
    Hi! Simulation areas can be placed on top of each other, and the effect will be the sum of the displacements created on each one. The problem is that you cannot tell Water Interactive objects which Simulation Areas should they affect. (If the feature is important to you , I encourage you to create an Enhancement Issue on github - it will be easy to implement, but the bug-fixes are a priority for now)

    @Nexusmaster
    Unfortunately I have to focus on the issues with stable-past&current Unity versions, and at that moment, I just do not have time for beta versions.
     
    ftejada likes this.
  4. DenisLemos

    DenisLemos

    Joined:
    May 1, 2015
    Posts:
    302
    Hi!
    I'm facing some problems with the depth buffer when using PlayWay. So before upgrading to Ultimate Water System, I'd like to know if there is any way to work around the problem or if it has already been fix.

    The fog of my sky system(Azure[Sky]) is an image effect, so it's applied to the scene based on the depth buffer. My fog works similar to Unity's GlobalFog, so this problem is also noticeable with the Unity GlobalFog effect.

    When I add the fog image effect to the camera, everything works perfectly in an aerial view as can be seen in the following image.
    PlayWay1.jpg
    But when I approach the camera at the waves level to look at the horizon, something strange seems to happen with the depth buffer.
    PlayWay2.jpg


    This should be related to the alpha blending, because when I disable the "Allow Alpha Blending" option in the Edit>Project Setting>Water Quality, the depth buffer works properly again, but that way I lose a fundamental feature of the water system, which is transparency. The same happens if I deactivate the 'Blend Edges' and 'Refraction' options in the 'Water.cs' script.
    PlayWay3.jpg

    I really like this water system, so I intend to use it in some demo footage of the new version of my sky system that I'm developing. I am implementing a profile system where each day will be a different profile and the weather will change from one profile to another based on weights.
    ClimateTab.jpg
    It is very similar to the profiles system of Ultimate Water System that I saw in this video. So making the Azure[Sky] climate system work with UWS will be very simple and easy.

    So I would be very happy to find a solution and even recommend UWS to my customers. I can even provide you with an Azure[Sky] voucher if necessary. Send me a private message if you want an Azure[Sky] voucher.

    Thank you,
    -Denis Lemos
     
    Last edited: Oct 24, 2017
    MCPGNZ and ftejada like this.
  5. StudioEvil

    StudioEvil

    Joined:
    Aug 28, 2013
    Posts:
    44
    Hi, does it work with Post Processing Stack v.2 ?
    I tried with Playway Water but water is rendered after the Depth of Field effect by example.
     
  6. Moonlit-Games-Studio

    Moonlit-Games-Studio

    Joined:
    Feb 11, 2014
    Posts:
    20
    Check your PM inbox - the voucher for UWS is there.
    We will definitively want to integrate UWS with other weather systems, including Azure SKY! :)
     
  7. Teila

    Teila

    Joined:
    Jan 13, 2013
    Posts:
    6,014
    So glad to hear this! Many of us use Enviro and would also love to see integration in the future. Now watch the requests come in. :)
     
  8. brave_mike

    brave_mike

    Joined:
    May 8, 2013
    Posts:
    25
    Strange things happen with "Image Effect Deferred":

    When the camera is e.g. 600 units above the water I see strange streaks in the water.
    This effect does not occur with "Default Queue" and "Image Effect Forward".
    It seems to be a problem with the terrain - when I turn off the terrain, the stripes in the water are gone!
    Also an increase of the "Near Clipplane" of the main camera brings a certain improvement. However only with very high values, which are not really usable.
    Has anyone observed the same problem? Is it a bug? Or did I do a setting wrong?

    MainCamera is on "Deferred"
    Color Space is "Linear"

    pic1.jpg pic2.jpg pic3.jpg
     
    Last edited: Oct 24, 2017
  9. Funkeys

    Funkeys

    Joined:
    Apr 16, 2017
    Posts:
    52
    +1
     
    SquadraCorse likes this.
  10. Funkeys

    Funkeys

    Joined:
    Apr 16, 2017
    Posts:
    52
    I either have this issue!
    I think it is a bug. Could be related to transparency, but that´s just a guess.

    What is your far clipping? Is it very high?

    For the the 3rd image, with the terrain turned off, I think it does not happen in 2017.2 anymore, but i have to take a look first to confirm.
     
    Last edited: Oct 24, 2017
  11. brave_mike

    brave_mike

    Joined:
    May 8, 2013
    Posts:
    25
    Thank you for your reply Funkeys. I do not think it's a problem with the far clipplane. I have made a very simple scene and the streaks are also there.

    Pic1.jpg

    And here is the same scene with a simple mesh in the water. The streaks are also there.

    pic2.jpg

    Unity Version 2017.1.0f3

    Created an Issue on github!
     
    Last edited: Oct 24, 2017
    Funkeys likes this.
  12. DenisLemos

    DenisLemos

    Joined:
    May 1, 2015
    Posts:
    302
    Thanks for the voucher!

    I am very happy to report that the current version of Azure[Sky] is working very well with UWS, the problems that occurred with PlayWay were gone. The issues with the depth buffer still seem to exist in DirectX 9, but this is not a problem because Unity will stop supporting DirecX 9 very soon. https://blogs.unity3d.com/pt/2017/07/10/deprecating-directx-9/

    For those of you using Azure[Sky] and UWS, I'll give you some quick tips on how to get around potential issues.

    With Render Mode set to 'Image Effect Deferred' in the "Water Camera" script, no problem occurred, everything worked exactly as it should.
    UWS1.jpg




    But by setting Render Mode to 'Image Effect Forward' or 'Image effect Queue', the fog scattering showed some artifacts on the horizon line.
    UWS2.jpg
    This happens because the fog scattering has a command to return the screen image if the depth buffer is equal to 1.
    Code (CSharp):
    1. if(depth == 1.0) return float4(screen, 1.0);
    This prevents the fog from covering the skybox, but at the same time, this causes the fog scattering not to be applied to the scene when the depth buffer equals 1. Then when the water is far away on the horizon, it will send to the depth buffer the value equal to 1, and consequently the fog scattering will not be applied to those pixels.

    Although the problem is related to the fog scattering effect, there is a very simple modification that can be done in the depth buffer of the water.

    Open the UWS 'Depth Copy' shader in "Shaders/Utility" folder and change this code snippet:
    Code (CSharp):
    1. v2f vert(appdata_t v)
    2. {
    3.     v2f o;
    4.     o.vertex = float4(v.vertex.xyz, 1.0);
    5.     #if UNITY_SINGLE_PASS_STEREO
    6.     o.vertex.x = o.vertex.x * 1.0;
    7.     #endif
    8.     //o.vertex = mul(UNITY_MATRIX_MVP, v.vertex);
    9.     o.texcoord = v.texcoord.xy;
    10.     return o;
    11. }
    To this:
    [EDITED] This will work better!
    Code (CSharp):
    1. v2f vert(appdata_t v)
    2. {
    3.     v2f o;
    4.     o.vertex = float4(v.vertex.xyz, 1.0);
    5.     #if UNITY_SINGLE_PASS_STEREO
    6.     o.vertex.x = o.vertex.x * 1.0 - 0.001;
    7.     #endif
    8.     //o.vertex = mul(UNITY_MATRIX_MVP, v.vertex);
    9.     o.texcoord = v.texcoord.xy - 0.001;
    10.     return o;
    11. }
    This prevents water from sending a value equal to 1 to the depth buffer and the artifacts on the horizon go away.
    UWS3.jpg
    This is a workaround, but it is best for game performance. I am going to fix this in Azure[Sky] and put an option in the Inspector to use or not the return command if the depth is equal to 1. This command is important for performance because it prevents all calculations from the fog scattering being calculated where it is showing only the skybox on the screen which makes no sense to spend performance calculating the fog in pixels where it will not be used.




    Another tip is to attach the fog scattering effect to the camera before the 'Water Camera' script. This will make the fog scattering work properly with the UWS underwater effect.
    UWS4.jpg
     
    Last edited: Oct 24, 2017
  13. JonasPersson

    JonasPersson

    Joined:
    Aug 14, 2016
    Posts:
    52
    Hi!
    I just upgraded from playway water to ultimate...

    We are having problems when building, we are getting fatal errors and are unable to build. We run Unity 2017.1.1.f1
    These are the errors we get, i also attached the log file from the editor:

    Assertion failed: Shader compiler: internal error compiling shader snippet type=1 platform=4: Failed writing data to socket

    Assertion failed: Shader compiler: internal error compiling shader snippet type=1 platform=1: Protocol error - failed to read correct magic number

    Shader error in 'UltimateWater/Refraction/Collect Light': Internal error communicating with the shader compiler process

    Shader error in 'UltimateWater/Refraction/Collect Light': Failed to find parameters of a compiled D3D9 shader (on d3d9)

    Compiling Fragment program with DIRECTIONAL
    Platform defines: UNITY_ENABLE_REFLECTION_BUFFERS UNITY_USE_DITHER_MASK_FOR_ALPHABLENDED_SHADOWS UNITY_PBS_USE_BRDF1 UNITY_SPECCUBE_BOX_PROJECTION UNITY_SPECCUBE_BLENDING UNITY_ENABLE_DETAIL_NORMALMAP SHADER_API_DESKTOP UNITY_COLORSPACE_GAMMA
     

    Attached Files:

  14. KatoSet

    KatoSet

    Joined:
    Oct 10, 2013
    Posts:
    5
    @JonasPersson:

    Make sure to set the color space from GAMMA to LINEAR.
    Make sure to remove d3d9 and only have d3d11 (Edit/ProjectSettings/PLayer/OtherSettings)
     
    brave_mike likes this.
  15. Funkeys

    Funkeys

    Joined:
    Apr 16, 2017
    Posts:
    52
    Ok I can confirm that this gray planes on the horizon are gone in 2017.2.0f3, what is left are the streaks.
     
    brave_mike likes this.
  16. roberteker

    roberteker

    Joined:
    Feb 22, 2017
    Posts:
    140
    Just a quick question:

    Is the current sale the Playway upgrade discount, or how do I get that?
     
  17. Moonlit-Games-Studio

    Moonlit-Games-Studio

    Joined:
    Feb 11, 2014
    Posts:
    20
    Until the end of October the price of upgrade from PWS to UWS is $50 only, and after that $75, starting November.
     
    syscrusher likes this.
  18. JonasPersson

    JonasPersson

    Joined:
    Aug 14, 2016
    Posts:
    52
    Thanks Katoset! i can now do a build:)

    To my next problem:
    My planar reflections are sort of duplicated and offsetted in a strange manner. When you have completly flat water this is not visible, but the atifact turns up as soon as you start adding a little bit of waves. (when you adjust the planar reflection offset slider you just move all 4 reflections up and down, they still have the same offset from eachother)
     

    Attached Files:

  19. brave_mike

    brave_mike

    Joined:
    May 8, 2013
    Posts:
    25
    Hello Jonas, look at the post from zuzzu. He explained the settings for reflections very well. Maybe it'll help you.;)
     
    Moonlit-Games-Studio likes this.
  20. brave_mike

    brave_mike

    Joined:
    May 8, 2013
    Posts:
    25
    @MCPGNZ I need the "wavelevel" for the current water underneath the camera (for boundless and for water volumes). For boundless water I can query the current wave height with

    "waterLevel = waterSample.GetAndReset(transform.position).y" (WaterCamera.cs at line 1006)

    How does this work for water volumes (additive water)?

    Here is my simple test script (works with boundless water, not with additive):

    Code (CSharp):
    1. namespace UltimateWater
    2. {
    3.     using Internal;
    4.     using System.Collections.Generic;
    5.     using UnityEngine;
    6.     using UnityEngine.Events;
    7.     using UnityEngine.Rendering;
    8.  
    9.     public class WaterLevel : MonoBehaviour {
    10.  
    11.         private float waterLevel = 0.0f;
    12.      
    13.         void Update () {
    14.  
    15.                 waterLevel = GetComponentInChildren<WaterCamera>().WaterLevel;
    16.  
    17.                 Debug.Log(waterLevel);
    18.          
    19.         }
    20.     }
    21. }
    22.  
     
    Last edited: Oct 26, 2017
  21. brave_mike

    brave_mike

    Joined:
    May 8, 2013
    Posts:
    25
    Ok - that was another question I could answer myself after some research:

    I have changed the code in the "WaterCamera.cs" at line 994 from this:

    Code (CSharp):
    1.                 if (newWater != null && newWater.Volume.Boundless)
    2.                 {
    3.                     waterSample = new WaterSample(containingWater, WaterSample.DisplacementMode.Height, 0.4f);
    4.                     waterSample.Start(transform.position);
    5.                 }
    To this:
    Code (CSharp):
    1.                  if (newWater != null && (newWater.Volume.Boundless || newWater.Volume.HasRenderableAdditiveVolumes))
    2.                 {
    3.                     waterSample = new WaterSample(containingWater, WaterSample.DisplacementMode.Height, 0.4f);
    4.                     waterSample.Start(transform.position);                  
    5.                 }
    Now my query code is running correctly.:D
    I don't know if this change will affect the performance!:rolleyes:
     
    Last edited: Oct 27, 2017
  22. MCPGNZ

    MCPGNZ

    Joined:
    Sep 29, 2016
    Posts:
    27
    Hi!

    I'll release new fixes tomorrow, those include mentioned problems with deferred
    ( @brave_mike , @Funkeys )

    I'll notify you when they will be available through the hot-fix page
    (i want to do some more testing)

    @_7stars
    Great to hear that everything integrated nicely.
    I'll check if the changes do not brake anything, and if so I'll add the depth bias to the UWS source to support Azure[sky] out of the box .

    @JonasPersson
    I do believe that the problems will disappear after new hot-fix release, but if not - notify mi through this github page
     
  23. DenisLemos

    DenisLemos

    Joined:
    May 1, 2015
    Posts:
    302
    Hi!
    My first attempt was to change the "Depth Copy" shader to this.
    Code (CSharp):
    1.     v2f vert(appdata_t v)
    2.     {
    3.         v2f o;
    4.         o.vertex = float4(v.vertex.xyz, 1.0);
    5.         #if UNITY_SINGLE_PASS_STEREO
    6.         o.vertex.x = o.vertex.x * 1.0 * 0.9;
    7.         #endif
    8.         //o.vertex = mul(UNITY_MATRIX_MVP, v.vertex);
    9.         o.texcoord = v.texcoord.xy * 0.9;
    10.         return o;
    11.     }
    12.  
    But this also altered the position of the waves in the depth buffer causing a phantasmagoric effect in the waves, because the fog scattering detected the waves a little above the actual position of the waves in the scene.

    So I changed the code for this one, and it seems to be working, I did not notice any changes in the position of the waves in the depth buffer.
    Code (CSharp):
    1.     v2f vert(appdata_t v)
    2.     {
    3.         v2f o;
    4.         o.vertex = float4(v.vertex.xyz, 1.0);
    5.         #if UNITY_SINGLE_PASS_STEREO
    6.         o.vertex.x = o.vertex.x * 1.0 - 0.001;
    7.         #endif
    8.         //o.vertex = mul(UNITY_MATRIX_MVP, v.vertex);
    9.         o.texcoord = v.texcoord.xy - 0.001;
    10.         return o;
    11.     }
    12.  
    But this should not be the best solution, since changing the position of the vertex shader is not ideal. The best solution would be to limit the depth output to something like.
    Code (CSharp):
    1. depth = clamp(depth, 0.0, 0.9);
    2. //or
    3. depth = clamp(depth, 0.0, 0.99);
    I tried to use clamp(value, min, max) on the fragment outputs of the "Depth Copy" shader, but it did no effect.



    If this modification I did not break anything in UWS, then the problem is solved. But if the change breaks something in UWS, then I think it should have a toogle to limit the water depth so it does not get a value equal to 1.

    I believe most of the Asset Store sky systems work the same way, not applying the fog in the scene if the depth is equal to 1 to avoid the fog covering the skybox. So this solution should make UWS work with all other sky systems.

    Even has how to fix this in Azure[Sky], but it would be necessary for the image effect render two RenderTextures, one for the scene and another just for the sky. And when the depth equals 1, just return the RenderTexture of the sky instead of the scene RenderTexture that contains that little bit of water on the horizon with no fog applied over. But this solution is extremely poor for performance.

    Ps: What's strange, is that by changing the Water Render Mode to "Image Effect Deferred" the water depth works normally without having to make any changes to the "Depth Copy" shader.
     
    ftejada, brave_mike and MCPGNZ like this.
  24. ch0kk0

    ch0kk0

    Joined:
    Jan 20, 2016
    Posts:
    22
    How do we set this up after adding ShipBowWavesEmitter script to child object of ship ?
     
    Last edited: Oct 27, 2017
  25. John-G

    John-G

    Joined:
    Mar 21, 2013
    Posts:
    1,062
    Anyone using Truesky with UWS, just tried the two together and clouds are being cut off by the water. That is they are showing behind the water and being cutt of at the horizon.
     
    DCrosby and brave_mike like this.
  26. roberteker

    roberteker

    Joined:
    Feb 22, 2017
    Posts:
    140
    Well, I've tried to purchase it for a few days now, both using Chrome (the purple check out button just spins) and Internet Explorer (where the cart simply refuses to show up), and the Asset Store isn't letting me.

    I've contacted the Unity support in two different ways, but I haven't heard anything back.
     
  27. InstigateMobile

    InstigateMobile

    Joined:
    Jul 13, 2016
    Posts:
    7
    Hi,

    We're wondering if there configuration to have different color and wave profiles for separate areas.

    Thank you.
     
  28. Bartolomeus755

    Bartolomeus755

    Joined:
    Jun 20, 2013
    Posts:
    140
    Hi ch0kk0,

    Here is bow wave setup of the child object.
    [​IMG]

    And I have added the wave particle script to the water gameobject.
    [​IMG]

    With this setup I have the bow wake effect in the picture above. I hope this helps.
     
  29. brave_mike

    brave_mike

    Joined:
    May 8, 2013
    Posts:
    25
    @MCPGNZ

    1) I have a problem with shadows and UWS 1.01.

    In the first picture you can see the shadow generated by UWS on the water surface. That's all right. But where is the shadow that should fall on the bottom of the sea?

    pic1.jpg

    Shouldn't it look like picture 2 (Picture montage)?
    I also found no way to bring the shadow only on the bottom of the sea!

    pic2.jpg

    This happens in all UWS render modes.

    2) I also tried the hotfix b1.
    Here the shadows are only on the seabed and no longer on the water surface?!

    And one more thing with b1:
    When you go underwater and look up, the water surface is no longer visible in "Default Queue" and with "Image Effect Forward". ("Image Effect Deferred" is ok)

    The tests were done with a new Unity project and only UWS.

    Setup:
    Unity 2017.1.0f3 and Unity 2017.2.0f3
    Lightmode: Linear
    Camera-render-path: Deferred
    Only one directional light as shadowcaster

    Am I doing something wrong? Should I create an issue on Github?
     
    Last edited: Oct 28, 2017
    Funkeys likes this.
  30. DCrosby

    DCrosby

    Joined:
    Jan 13, 2013
    Posts:
    81
    I have some pretty dense terrain around the water, created by Terrain Composer, what seems like Decades ago, when I first started my project, and the terrain and the city on the shore I don't want to re-do from scratch with new tools, but since I don't need to edit it anymore, I can convert it to traditional terrain, and remove all the scripts, but regardless of if I remove the scripts or not, I get the following errors:

    The combined number of detail object vertices in one single patch is exceeding the limit (65k). Try decreasing detail density or detail resolution per patch.
    UnityEngine.Camera:Render()
    UltimateWater.PlanarReflection:RenderReflection(Camera, Camera) (at Assets/Ultimate Water System/Scripts/PlanarReflection.cs:214)
    UltimateWater.PlanarReflection:OnWaterRender(WaterCamera) (at Assets/Ultimate Water System/Scripts/PlanarReflection.cs:154)
    UltimateWater.Water:OnWaterRender(WaterCamera) (at Assets/Ultimate Water System/Scripts/Water.cs:551)
    UltimateWater.WaterRenderer:RenderEffects(WaterCamera) (at Assets/Ultimate Water System/Scripts/WaterRenderer.cs:125)
    UltimateWater.WaterCamera:RenderWaterEffects() (at Assets/Ultimate Water System/Scripts/WaterCamera.cs:781)
    UltimateWater.WaterCamera:OnPreCull() (at Assets/Ultimate Water System/Scripts/WaterCamera.cs:501)​

    Then I get a lot, and by a lot I mean thousands of Failed creating system: and some hexadecimal value. This is after gameplay concludes, and I then have to disable and re-enable all terrain tiles, to get it to stop, otherwise after a couple of minutes it takes unity with it sometimes...
     
  31. brave_mike

    brave_mike

    Joined:
    May 8, 2013
    Posts:
    25
    Trying a little more with the shadows tonight.

    There are different settings with UWS:

    e. g. under "Water -> Planar Reflection - > Render Shadows" - has no effect.

    In the" Shader Set" under "Reflection & Refraction - > Receive Shadows" - also has no effect.

    Then there is a script under "Effects - WaterShadowCastingLight" - but when I put it on the light source it has no effect.

    I think it's a bug - so I created an issue on Github.
     
    ftejada likes this.
  32. JonasPersson

    JonasPersson

    Joined:
    Aug 14, 2016
    Posts:
    52
    Hi!

    I have another problem.
    When i use the Ultimate water (it was the same in playway water) i get really bad banding artifacts in the skydome that i use (Azure sky).

    1. The banding appears when a Underwater IME scrips is attached to the camera.
    (in playmode the banding disappears when you turn off the Water camera script)

    2.The banding only appears in the VR camera (its a steam vr project)

    3. The banding only appears in Linear color

    4. I tried both single and multipass rendering, banding in both cases.

    Any ideas of how to solve this?
     

    Attached Files:

  33. MCPGNZ

    MCPGNZ

    Joined:
    Sep 29, 2016
    Posts:
    27
    Hi!

    I just added new hot-fix for download.
    You can read what was changed here.
    I've also added very-basic scene with the added ShipBowWaves.
    (i know they require some bigger changes and docs but this is for-now, bugs-first)

    I'll try to answer all your questions tomorrow.
     
  34. JonasPersson

    JonasPersson

    Joined:
    Aug 14, 2016
    Posts:
    52
    Hi again
    About the color banding..
    i just read in your documentation "with some settings, color banding may be visible, in that case, the easiest solution is to apply dithering, Unity provides free, " i missed this disclaimer before...

    This ist just when you are actually under the water right? Or is the banding you describe in the documentation always going to be visible when there is a Underwater IME in the scene?
     
  35. MCPGNZ

    MCPGNZ

    Joined:
    Sep 29, 2016
    Posts:
    27
    @JonasPersson
    Yes, this should be just under the water. I'll look into it, feel free to add this issue on github.
    Btw: You can try the newest hot-fix, it's possible that the problem will go away (I changed quite a few things in it).
     
  36. InstigateMobile

    InstigateMobile

    Joined:
    Jul 13, 2016
    Posts:
    7
    Hi @MCPGNZ

    Can we set different water colors and wave heights for different areas?
    Color and waves transitions between different areas should be in smooth to avoid cut-edge effects on read borders.

    Thank you.
     
    Last edited: Oct 30, 2017
  37. InstigateMobile

    InstigateMobile

    Joined:
    Jul 13, 2016
    Posts:
    7
    Hi @MCPGNZ

    We have issue with performance. When creating ~2000 buoyant objects, FPS is going down to 1. See screenshot for ~500 objects, FPS is 3-5. As you can see from screenshot, main load source is WaterPhysics.FixedUpdate() method.

    Thank you.
     

    Attached Files:

  38. JonasPersson

    JonasPersson

    Joined:
    Aug 14, 2016
    Posts:
    52
    Hi!

    Thanks for the update the banding is gone!! Great work!

    The issue with the multiple reflections was connected to the high quality setting in planar projections in the shader set. On normal setting, the multiple reflections disapeared, so for me that issue is solved :). (but maybe you want to look into the high quality setting and fix it)
     
    Last edited: Nov 1, 2017
    ftejada, MCPGNZ and brave_mike like this.
  39. InstigateMobile

    InstigateMobile

    Joined:
    Jul 13, 2016
    Posts:
    7
    Hi @MCPGNZ

    We have a problem during release build (see errors in screenshot). Issue reproduced on 5.6.3p4 and 5.6.4p1.
    UWS is the 1.01 with the latest patches. Please help.

    Thank you.
     

    Attached Files:

  40. snacktime

    snacktime

    Joined:
    Apr 15, 2013
    Posts:
    860
    I'm trying to get the water so you can't see through it as much. I thought that was what transmission was for but I can't notice any difference at all when I tweak the settings. This is linear/deferred.
     
  41. snacktime

    snacktime

    Joined:
    Apr 15, 2013
    Posts:
    860
    Nm it's working, just has no effect until you exit/enter play mode again
     
    Moonlit-Games-Studio likes this.
  42. stevenwanhk

    stevenwanhk

    Joined:
    Jul 20, 2016
    Posts:
    32
    Hi, I found that the refraction does not work with Single Pass
    1.jpg is Game View, you can see the terrain underwater part cannot be seen
    2.jpg is Scene View, it works normally

    If I change to Multi Pass, it works normally. Is it possible for this to be fixed? Thank you.
     

    Attached Files:

    • 1.jpg
      1.jpg
      File size:
      44.7 KB
      Views:
      31
    • 2.jpg
      2.jpg
      File size:
      28.3 KB
      Views:
      30
  43. Morcrist

    Morcrist

    Joined:
    May 7, 2015
    Posts:
    5
    Somehow I've lost the ability to be able to see the surface of my water when underwater. I want it to look like this:

    [​IMG]

    Where are the settings and/or what I need to enable to make it look like that?

    Thanks in advance for any pointers/help!

    EDIT: My apologies. I switched to Linear and it fixed it. :p
     
    Last edited: Nov 3, 2017
    Moonlit-Games-Studio likes this.
  44. sadicus

    sadicus

    Joined:
    Jan 28, 2012
    Posts:
    163
    Will you please post an image of how each demo should look? This is how the caustic scene looks.
    [​IMG]
    also with Underwater Effects demo if the camera is moved or rotated the particle effect is broken.
     
    Last edited: Nov 4, 2017
    Moonlit-Games-Studio likes this.
  45. DCrosby

    DCrosby

    Joined:
    Jan 13, 2013
    Posts:
    81
    I ended up reducing the terrain density from 2049 to 1025, and yes I know they're off by 1, due to terrain textures typically being power of 2, +1 row... but that fixed it.
     
    Moonlit-Games-Studio likes this.
  46. roberteker

    roberteker

    Joined:
    Feb 22, 2017
    Posts:
    140
    [​IMG]

    https://gfycat.com/gifs/detail/ImaginativeZigzagCentipede

    I'm trying a Water Volume Subtract, which I could never get to perform adequately in Playway (too much of a performance hit), and I haven't tested performance in Ultimate with this yet, but I'm seeing weird visual artifact inside of the hull.

    If I remove the boat alltogether and just leave the collider, I don't see it. So, I'm guessing these are reflections perhaps? Still, it renders in a place where it clearly should not.
     
  47. roberteker

    roberteker

    Joined:
    Feb 22, 2017
    Posts:
    140
    Can anyone in here recommend me a fog which works with a normal skybox and Ultimate water?

    Ultimate water is quite jarring in the distance as it is now.
     
  48. roberteker

    roberteker

    Joined:
    Feb 22, 2017
    Posts:
    140
    Sorry for spamming the thread, I just noticed that in the documentation it says to turn anti-aliasing off.

    Is that still the case? And if so, when will that be resolved?
     
  49. Galahad

    Galahad

    Joined:
    Feb 13, 2012
    Posts:
    54
    Hi Roberteker, it seems that it still part of the recommended workflow. But that doesn't forbid the use of post processing anti-aliasing, available on the default Unity Effects package.
     
    MCPGNZ likes this.
  50. MCPGNZ

    MCPGNZ

    Joined:
    Sep 29, 2016
    Posts:
    27
    @InstigateMobile
    If you want to transition between different water presets you can Water Profile Blend to change each profile influence based on your current position. Note that it will change the look of the whole water surface, but if you're talking about FPP it should be fine. (The setup is shown in Profile Blend demo scene, and the Water Profile Blend is attached to the Water component). About the physics - can you add Github entry with your hardware specs and ideally simple scene that kills the fps? The problem with compiling shaders is already on Github, but can you tell me is this happening every time, or just sometimes?

    @snacktime
    The changes in water transmission should be visible without the need to exit/enter playmode. Do you have the Synchronize toggle enabled in the Water component?

    @stevenwanhk
    I'll look into it.

    @Morcrist
    The underwater effects should work with any configuration, can you describe me what settings caused the underwater effect to disappear, what Unity version are you using, etc.?

    @sadicus
    Hey! I'll do that, no problem. Caustics works only with deferred rendering path and requires overriding Unity deferred shaders - Caustics demo scene, has a Light gameobject, with Light Water Effects script, there you should see the information about this (and the button to set the proper shaders).

    @roberteker
    I'll add this problem to the list; as for the fog, the one visible in this video is from DeepSky Haze, Azure[Sky] should also work without any problems (you can talk to the @DenisLemos about the details).
     
    Moonlit-Games-Studio likes this.