Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Troubles with Root motion (Mixamo)

Discussion in 'Animation' started by Havie, May 8, 2020.

  1. Havie


    Oct 12, 2019

    I am testing out a combo system, and I am having a hard time getting root motion to work properly.

    I have imported Several Animations off Mixamo, the way I figured out how to do this is:
    1) Import obj with idle anim - this is ur main character
    2) for all other anims you want, import the obj, expand the obj in inspected, select the animation, control+D to duplicate the animation out of the obj, delete the obj

    Following this guide (

    I proceed to
    Set on my main character obj,
    Rig--> root node to Hips
    Animation--> Motion -->Root Motion Node to Hips

    This didnt work
    So i turned that off, and this renabled settings under animations where I can check
    "Bake into Pose" etc but these also have no effect. Tried many different combinations here.

    The problem in game continues like this, the character warps back to start.

    Not sure where I am going wrong in this process

    Maybe its how im importing the animations, and that the animations are inside the main character .obj? because selecting the animations have no settings on them, simply "loop time" on or off.

    Any advice, Id appreciate.

    Thank you
    Last edited: May 8, 2020
    EZaca likes this.
  2. Havie


    Oct 12, 2019
    After tons of guides and testing.. ive found a solution:

    1) you cant use rig-->humanoid despite all guides saying too, must use generic or anims break

    2) You have to import all animations like with the meshes instead of duplicating and cloning them out and renaming. Only ontop of this like "prefab object" do you get settings for each individual avatar/animation , which is where you select Rig-->Generic-->Root node =hips This results in all your animations being named "" and theres nothing u can do about it...I was duplicating the anims out of this prefab object so i could rename/edit them.. which doesnt allow whatever this "rig" avatar system is to work properly

    If anyone has any neater- more clean solutions, I would be very interested. Thanks

    Attached Files:

  3. EZaca


    Dec 9, 2017
    Thank you for sharing! I realized my model was already ready for Mixamo with AnimationType=Generic, but for some reason, it did not work. Until I realized the Avatar was not set in the animation FBX. After setting it to the model avatar, it worked smoothly!

    Your post helped me to double-check the animation type and to set the root node to "Hips" :)
  4. LaireonGames


    Nov 16, 2013
    If you click on the animation tab for the file itself it will let you set the names of the clips it contains. You have to do it within that inspector rather than trying to rename the file as usual though
    Xientra likes this.


    Jun 8, 2013
    Screenshot 2023-11-29 112412.png

    Set apply root motion to enabled.
    felipemorenoptw likes this.
  6. iwillbenice


    Jun 7, 2013
    Hey guys. kinda digging thread from the grave, but none of the above made root motion working for me.

    I didn't manage to make root motion work but under the animation on .fbx I ticked `Lool Time` and 'Loop Pose` options and that made the walking animations work while not applying root motion at all, so it is usable for further development, but not really what I had in mind.