Search Unity

[SOLVED]Game runs from editor, only process starts from build

Discussion in 'Editor & General Support' started by rad1c, Jun 17, 2018.

  1. rad1c

    rad1c

    Joined:
    Feb 26, 2016
    Posts:
    21
    hi all,

    Here's my issue: My game worked as intended in Unity 2017, all versions, basically. I upgraded to 2018 (2018.1.2f1 (64-bit)), as well as added UBER Shader to the project.
    Everything seems to be working as intended from the Editor.

    But when I build the game and start the exe (Windows 7 x64, x64 build), the process starts, UnityCrashHandler64.exe starts along with it, but that's it. There's some "hourglassing" for about 2 seconds when I start the exe then nothing's on: I still see my desktop, like I never started the game, except, again, the process of it is still there in memory / Task Manager - the exe memory usage is stuck around 14.7K, 0% CPU use, so it feels like it was an idle background process...

    I tried to reimport everything, close everything, restart everything, delete previous build files and re-build, etc, no change.
    Everything works like charm from Editor, yet the standalone build doesn't start, except for the process as I described, which "runs" there forever.
    I have a strong impression the game doesn't even make it to try to load a script or start a scene or anything: none of my very early codes run when I start the exe, and the 1st scene is not at all complex (it is a super-simple menu UI only).

    Any helps is appreciated as I've no idea what to do now... I can't even find a way to try to debug the issue for not having any error.

    EDIT:
    Upgraded to Unity 2018.1.5f1 (64-bit) (I'm using Plus btw), nothing changed...
    No error in Dbgview, Event Viewer, Unity Log (player logging is switched on), as well as the same issue: the process starts but that's it.
    Please also note I have no antivirus running, and it seems Unity Engine itself fails to start.


    Thanks!
     
    Last edited: Jun 17, 2018
  2. rad1c

    rad1c

    Joined:
    Feb 26, 2016
    Posts:
    21
    As I can't delete the thread, I added [SOLVED] prefix.

    I sorted it out the above issue by rolling back from Unity 2018.Gamebreaker.Edition to 2017.latest - everything runs again...
    The source of the error most likely was UBER Shader. It does NOT work under Unity 2018 for unknown reasons, and it is also not noted on the Store Page, as well as there's no error or warning or anything in Unity 2018 when one imports UBER, or upgrades the project, or whenever.

    So it silently breaks your game and you'll find out when you build it AND run it the 1st time.

    IMPORTANT LESSON: If you upgrade to a new Unity version, build, run, test the project and roll back if it doesn't work, especially if it fails to start with no error message or anything...
     
unityunity