Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Bug My Unity Projects Won't Open!

Discussion in 'Unity Hub' started by Deky_, Mar 26, 2022.

  1. Deky_

    Deky_

    Joined:
    Sep 20, 2019
    Posts:
    5
    Out of nowhere, Unity Hub wouldn't open my projects anymore. Each time I try to open a project, it launches for 5 seconds then closes. I think it had to do something with licensing because I made a new project and I already started with 8 errors saying "the package is not available to use because there is no license registered for your user". I tried using every technique, deleting the license and adding it back, restarting my computer, etc. Yet nothing worked, please help me I'm lost.

    This is what happens when I create a new project... The licensing client is open, I do have a license but it's still not working. I'm currently using Windows 11 if that might be the cause of the issue but it was working just fine yesterday. I uninstalled, reinstalled Unity Hub and Unity but I get the same exact errors. I can't even open my project unless I open a scene in my files to open the editor and see the exact same errors.

     
  2. juaa

    juaa

    Joined:
    Feb 4, 2016
    Posts:
    10
    I'm having exactly the same error here, I'm using windows 10
     
  3. SteveCissel

    SteveCissel

    Joined:
    Mar 27, 2022
    Posts:
    2
    Same here. Unity Errors.JPG
     
  4. Deky_

    Deky_

    Joined:
    Sep 20, 2019
    Posts:
    5
    Did you figure out a way to fix it?
     
  5. juaa

    juaa

    Joined:
    Feb 4, 2016
    Posts:
    10
    No, I reported the problem, but support still hasn't given me a solution that works, try to do the same, you can report a bug using unity hub
     
  6. felipec_unity

    felipec_unity

    Unity Technologies

    Joined:
    Sep 3, 2020
    Posts:
    14
  7. Deky_

    Deky_

    Joined:
    Sep 20, 2019
    Posts:
    5
  8. juaa

    juaa

    Joined:
    Feb 4, 2016
    Posts:
    10
  9. felipec_unity

    felipec_unity

    Unity Technologies

    Joined:
    Sep 3, 2020
    Posts:
    14
    After adding the permissions, did you also quit the Editor and the Hub (and I mean really quit, not just close the window), and opened it again?

    Also, when checking the permissions, just to be sure, try to create an empty file in the Unity folder, just to be sure. (Windows: C:\ProgramData\Unity, Mac: Macintosh HD/Library/Application Support/Unity).
     
  10. juaa

    juaa

    Joined:
    Feb 4, 2016
    Posts:
    10
    Support found this solution and it worked for me, hope it works for you too
    1. Delete the license file "Unity_lic.ulf" (C:\ProgramData\Unity)(windows)
    2. Generate license request for manual activation in Hub (Hub > Preferences > Licenses > Add > Activate with license request > Create license request)
    3. Open that .alf file in your preffered text editor and add the following line into <MachineBindings> section: “<Binding Key="4" Value="" />” without the quotation marks
    4. Now proceed with activation and upload the modified .alf file to get the license
    5. Activate the license using the file .ulf that you downloaded
     
  11. EastEnderEmpire

    EastEnderEmpire

    Joined:
    Mar 28, 2022
    Posts:
    4
    When you write .alf file, do you mean the .ulf file? OTherrwise I don't know what .alf file you're talking about

    Edit: Sorry, I worked it out. The fix seems to work for me!
     
    Last edited: Apr 1, 2022
  12. Deky_

    Deky_

    Joined:
    Sep 20, 2019
    Posts:
    5
    I tried generating a new license manually as mentioned before yet it's still not work.

    The file below shows what's happening on my side; it looks like my Unity Hub "refreshes" when I open a project. We can see my project about to open but then it closes for the editor to never open... It's been 2 weeks I had this issue, I'm so lost.

    Edit: The gif cropped for some reason but my the Unity "loading screen" just closes out of nowhere.
     

    Attached Files:

  13. saurabhs_

    saurabhs_

    Joined:
    Feb 13, 2015
    Posts:
    1
    had the same problem, downgrade your hub to v2 and then activate the license
    once activated from v2, you can upgrade unity hub to v3.1.1

    @felipec_unity please share the same in other forums and share an older version of unity hub for us to download since only the latest 3.1.1 is available on unity download page
     
  14. felipec_unity

    felipec_unity

    Unity Technologies

    Joined:
    Sep 3, 2020
    Posts:
    14
    Hi Deky_, the behavior you experience happens when the Editor doesn't have access to a valid license.

    There are a couple of known issues that could cause that. One is the permission I mentioned before. The other is what juaa and EastEnderEmpire mentioned (Binding 4).

    Note that when attempting the Binding 4 work around, it has to be added before Binding 5 in the ALF file.

    If you tried all that and it still didn't work, it's probably better to open a support ticket.
     
  15. SteveCissel

    SteveCissel

    Joined:
    Mar 27, 2022
    Posts:
    2
    The information above worked for me.
    Here it is consolidated:

    1. Delete the license file "Unity_lic.ulf" (C:\ProgramData\Unity)(windows)
    2. Generate license request for manual activation in Hub (Hub > Preferences > Licenses > Add > Activate with license request > Create license request)
    3. Open that .alf file in your preffered text editor and add the following line into <MachineBindings> section: “<Binding Key="4" Value="" />” without the quotation marks
    4. Now proceed with activation and upload the modified .alf file to get the license
    5. Activate the license using the file .ulf that you downloaded

    Note: When attempting the Binding 4 work around, it has to be added before Binding 5 in the ALF file.

    #Onward
    ~ Steve
     
    samanabo, felipec_unity and GGeovani like this.
  16. Deky_

    Deky_

    Joined:
    Sep 20, 2019
    Posts:
    5
    Here's a fix for the problem:
     
    martinzavrel90 likes this.
  17. cookim_snookims

    cookim_snookims

    Joined:
    Jun 24, 2022
    Posts:
    1
    THANK YOU SO MUCH!!! This worked perfectly, thank you so much for posting this!!