Search Unity

  1. Unity 2020.1 has been released.
    Dismiss Notice
  2. We are looking for feedback on the experimental Unity Safe Mode which is aiming to help you resolve compilation errors faster during project startup.
    Dismiss Notice
  3. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Bug Ctrl+Z shortcut not working with non-english keyboard layout

Discussion in 'Linux Editor' started by pavethem, Apr 19, 2019.

  1. pavethem

    pavethem

    Joined:
    Feb 22, 2019
    Posts:
    1
    Ctrl+Z works fine when using english keyboard layout, but when using my native german layout, it does not work.
    Curiously, other keyboard shortcuts (like Ctrl+D) do work.
    This has been the case since the 2018 versions of Unity but is not fixed in 2019.1.0f2.
    Tested this on Arch and Debian Buster both running Gnome.
     
  2. PixelJ

    PixelJ

    Unity Technologies

    Joined:
    Nov 1, 2018
    Posts:
    196
  3. Achie1

    Achie1

    Joined:
    Jan 14, 2018
    Posts:
    18
    I have the same problem too. I used AZERTY (French Keyboard)
    Ubuntu 2019.10
     
  4. Achie1

    Achie1

    Joined:
    Jan 14, 2018
    Posts:
    18
    For the time being, you can resolve it by adding a custom shortcut. Go to Edit, Shorcut ans add the shortcut you want for Undo
     
  5. Ytho_01

    Ytho_01

    Joined:
    Feb 6, 2020
    Posts:
    1
    Any news on this? Same problem here with an azerty french keyboard layout : I have to Ctrl+W for Ctrl+Z, Ctrl+Q for Ctrl+A, still, when I type a name for a gameobject, a string value or whatever, no problem, A is A, Q is Q etc.

    Ubuntu 18.04
    Unity 2018.4.17f1
     
  6. APSchmidt

    APSchmidt

    Joined:
    Aug 8, 2016
    Posts:
    3,686
    I complained about that some time ago. It appears that it's a known bug that is still to be fixed. It won't be fixed in old versions though. Maybe it will in LTS versions and 2020.

    In the meantime, just remap your shortcuts (Edit)Shortcuts...) so that if feels like to you that you are using Ctrl+Z and the other keys. That's what I did, in the shortcuts setting Ctrl+z becomes Ctrl+w but I actually use Ctrl+z on my keyboard. :)

    Screenshot_2020-03-16_14-31-37.jpg
     
  7. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    2,114
  8. APSchmidt

    APSchmidt

    Joined:
    Aug 8, 2016
    Posts:
    3,686
    It seems to be fixed but now the space bar is not recognized, at least it isn't in a18.

    How to reproduce:
    1. create a new empty project with 2020.2.0a18,
    2. add the following script to the camera and press Play.
    Code (CSharp):
    1. using UnityEngine;
    2.  
    3. public class Test : MonoBehaviour
    4. {
    5.     // Start is called before the first frame update
    6.     private void Start()
    7.     {
    8.         Debug.Log("Hello, World!");
    9.     }
    10.  
    11.     // Update is called once per frame
    12.     private void Update()
    13.     {
    14.         if (Input.GetKeyDown(KeyCode.Space))
    15.             Debug.Log("The space bar has been pressed.");
    16.        
    17.         if (Input.GetKeyDown(KeyCode.A))
    18.             Debug.Log("The A key has been pressed.");
    19.     }
    20. }
     
    Last edited: Jul 25, 2020
unityunity