Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on Dec 8, 2022, between 7 am & 7 pm EST, in the DOTS Dev Blitz Day 2022 - Q&A forum, Discord, and Unity3D Subreddit to learn more about DOTS directly from the Unity Developers.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Question Can't build any Sample project of tiny on IOS platform

Discussion in 'Project Tiny' started by mlafrenaye, Jun 22, 2021.

  1. mlafrenaye

    mlafrenaye

    Joined:
    Jan 25, 2021
    Posts:
    3
    Hi !
    So I have been trying to build Tiny Racing, Tiny Aquarium, and Tiny 3D with Unity 2020.1.17 (with IOS module installed) and Xcode 12.5 on a Mac. In the doc for tiny it says
    • The Editor platform must be set to `PC, Mac & Linux Standalone`, unexpected errors may showup if the Editor is switched to different platforms
    So I am staying on this platform. But I have this error below for every single project whenever I build for Mac or for IOS (I am using the build configuration in the build folder of the project).
    And when I build it on my Windows computer both build for dotnet dans il2cpp works but the build for IOS is throwing the same error as this post : https://forum.unity.com/threads/tiny2d-ios-build-failure.1110089/
    Is it a bug with IOS and Mac ?
    I can't find anything on how to solve this.

    Here is the log:

    Build iOS failed after 8.50s.
    Process terminated. Infinite recursion during resource lookup within System.Private.CoreLib. This may be a bug in System.Private.CoreLib, or potentially in certain extensibility points such as assembly resolve events or CultureInfo names. Resource name: Arg_AccessViolationException
    at System.Environment.FailFast(System.String)
    at System.SR.InternalGetResourceString(System.String)
    at System.SR.GetResourceString(System.String, System.String)
    at System.AccessViolationException..ctor()
    at System.Reflection.CustomAttribute.FilterCustomAttributeRecord(System.Reflection.MetadataToken, System.Reflection.MetadataImport ByRef, System.Reflection.RuntimeModule, System.Reflection.MetadataToken, System.RuntimeType, Boolean, ListBuilder`1<System.Object> ByRef, System.RuntimeType ByRef, System.IRuntimeMethodInfo ByRef, Boolean ByRef, Boolean ByRef)
    at System.Reflection.CustomAttribute.AddCustomAttributes(ListBuilder`1<System.Object> ByRef, System.Reflection.RuntimeModule, Int32, System.RuntimeType, Boolean, ListBuilder`1<System.Object>)
    at System.Reflection.CustomAttribute.GetCustomAttributes(System.Reflection.RuntimeModule, Int32, Int32, System.RuntimeType)
    at System.Reflection.CustomAttribute.GetCustomAttributes(System.Reflection.RuntimeAssembly, System.RuntimeType)
    at System.Reflection.RuntimeAssembly.GetCustomAttributes(System.Type, Boolean)
    at System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, Boolean)
    at System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, Boolean)
    at System.Reflection.CustomAttributeExtensions.GetCustomAttribute[[System.__Canon, System.Private.CoreLib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e]](System.Reflection.Assembly)
    at System.Resources.ManifestBasedResourceGroveler.GetNeutralResourcesLanguage(System.Reflection.Assembly, System.Resources.UltimateResourceFallbackLocation ByRef)
    at System.Resources.ResourceManager.CommonAssemblyInit()
    at System.Resources.ResourceManager..ctor(System.Type)
    at System.SR.get_ResourceManager()
    at System.SR.InternalGetResourceString(System.String)
    at System.SR.GetResourceString(System.String, System.String)
    at System.AccessViolationException..ctor()
    at System.Collections.Generic.Dictionary`2[[System.__Canon, System.Private.CoreLib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e],[System.__Canon, System.Private.CoreLib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e]].TryGetValue(System.__Canon, System.__Canon ByRef)
    at System.AppContext.GetData(System.String)
    at System.AppContext.get_BaseDirectory()
    at Microsoft.CodeAnalysis.CommandLine.BuildClient.Run(System.Collections.Generic.IEnumerable`1<System.String>, Microsoft.CodeAnalysis.CommandLine.RequestLanguage, Microsoft.CodeAnalysis.CommandLine.CompileFunc)
    at Microsoft.CodeAnalysis.CSharp.CommandLine.Program.MainCore(System.String[])
    at Microsoft.CodeAnalysis.CSharp.CommandLine.Program.Main(System.String[])
    *** buildprogrambuildprogram build failed (0.17 seconds), 1 items updated, 7 evaluated

    UnityEngine.Debug:LogError(Object, Object)
    Unity.Build.ResultBase:LogResult() (at Library/PackageCache/com.unity.platforms@0.10.0-preview.10/Editor/Unity.Build/ResultBase.cs:65)
    Unity.Build.Editor.<>c:<.cctor>b__34_0(BuildConfiguration) (at Library/PackageCache/com.unity.platforms@0.10.0-preview.10/Editor/Unity.Build.Editor/BuildConfigurationInspector.cs:42)
    Unity.Build.Editor.<>c__DisplayClass30_0:<Build>b__1() (at Library/PackageCache/com.unity.platforms@0.10.0-preview.10/Editor/Unity.Build.Editor/BuildConfigurationInspector.cs:128)
    UnityEngine.GUIUtility:processEvent(Int32, IntPtr, Boolean&) (at /Users/bokken/buildslave/unity/build/Modules/IMGUI/GUIUtility.cs:189)
     
    Last edited: Jun 22, 2021
    code-kiwi likes this.
  2. RoughSpaghetti3211

    RoughSpaghetti3211

    Joined:
    Aug 11, 2015
    Posts:
    1,688
    Are you building using the platforms scriptable objects?
     
  3. mlafrenaye

    mlafrenaye

    Joined:
    Jan 25, 2021
    Posts:
    3
    Do you mean the IOS.buildconfiguration file located in the build folder ? I so, yes I use this :

    upload_2021-6-22_22-20-59.png

    I haven't modify the sample project at all, I have opened it and tried to build on IOS with the build configuration file ... is there something else I am supposed to do before building the samples ?
    Seems there is nothing else in the doc ...
     
  4. goldenyz

    goldenyz

    Joined:
    Jun 23, 2021
    Posts:
    1
    M1 Chips? I encountered the same issue. Could any one help?
     
    code-kiwi likes this.
  5. code-kiwi

    code-kiwi

    Joined:
    Apr 29, 2017
    Posts:
    4
    I'm having the same issue in normal Unity 2019.4.28f1 (latest 2019.4).

    An empty Unity project builds fine, but I get this same issue in a small demo project.
     
  6. KGArtie

    KGArtie

    Joined:
    Nov 4, 2021
    Posts:
    1
    I'm experiencing a similar issue with the
    Process terminated. Infinite recursion during resource lookup within System.Private.CoreLib.
    error. This happens whether I use a sample project or build a new DOTS project from scratch. I'm using Unity 2020.1.17f1 and a MacBook Pro with an Apple M1 (Silicon) chip and macOS 12.0.1.