Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on Dec 8, 2022, between 7 am & 7 pm EST, in the DOTS Dev Blitz Day 2022 - Q&A forum, Discord, and Unity3D Subreddit to learn more about DOTS directly from the Unity Developers.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Bug Cannot open any version of Unity, in any way, at all - all roads lead back to Unity Hub

Discussion in 'Unity Hub' started by Tor-Vestergaard, May 22, 2020.

  1. Tor-Vestergaard

    Tor-Vestergaard

    Joined:
    Mar 20, 2013
    Posts:
    177
    After days of debugging this issue, I have given up, and humbly seek help from here. I recently acquired a new desktop, and something has gone dreadfully, dreadfully wrong with Unity Hub.

    I cannot open any project in any version of Unity that knows Unity Hub exists. It is as if all versions of Unity have a "go to Hub" redirect that is always triggering, without fail. The project will briefly appear to start opening, but will then stop opening and return to the Unity Hub. A message will then flash into existence for literally one frame, but with recording software I can stop on that frame and see what it says:

    upload_2020-5-22_13-57-26.png

    ???

    I am a developer of Odin Inspector, and I have (had) some trust in my by now rather intimate knowledge of Unity's inner workings, so I'd hoped I would at least be able to figure this issue out on my own, but now I am truly at the end of my rope. Please help! :eek: I can't work any more! I cannot reproduce customer issues in versions of Unity that know about the Hub! I cannot test Odin!

    All I did originally was install Unity 5.3 (our development version of Unity, which happily still works, being blessedly free of Unity Hub's interference). Then I installed Unity Hub, and started installing a bunch of versions of Unity. But alas, none of them have worked at all. For a brief period, I could open them by manually creating and editing the ProjectVersion.txt file to the version I want to open, and then manually opening a scene file in the project, but now that has stopped working as well for reasons unknown to me.

    Here are the things I have tried so far:

    - Run the hub as administrator.
    - Open Unity via command line arguments with the "-projectPath" argument, supposedly "bypassing" the Hub according to this forum; alas, the dreaded Hub will still end up being opened instead. No combination of command line arguments I have tried seem to successfully open Unity. And I have tried a lot; I wrote a program that would combine a ton of them in different ways and let it run for a few hours to see if any argument variation opened Unity properly. None did.
    - Uninstall and reinstall the broken versions of Unity via the hub (all of them).
    - Uninstall and reinstall the hub, in different locations on my computer (in case Program Files permissions issues were causing any trouble).
    - Uninstall the hub and remove all files related to it from my computer (located using Search Everything) and also manually search and clean the registry of anything that looks remotely related to the hub, and then install the Hub again. No go.
    - Uninstall the hub and try to run Unity without it installed. Unity complains the hub is not installed.
    - Returned my license and reclaimed it. Tried generating a new Personal license.
    - Logged into a different account with a different license. All accounts attempted work fine on other computers.

    Things I have not tried so far:

    - Reinstalling Windows (please don't make me do this).
    - Doused my desktop in consecrated Holy Water.
    - Contact you guys and plead for help.

    Of those three, I pick the last, for now. What can I do to actually open Unity, so I can please get back to work?

    Yours sincerely,

    A frustrated and moderately desperate Asset Store developer
     
  2. Tor-Vestergaard

    Tor-Vestergaard

    Joined:
    Mar 20, 2013
    Posts:
    177
    Okay, somewhat embarrassingly, another person on this forum apparently recently had the extraordinary luck to figure out what this issue was, and my prior Googling somehow missed that thread. Here is the solution, for those of you unfortunate enough to encounter this utterly bewildering issue.

    Even more embarrassing is the nature of the issue, and the Unity Hub guys (or whoever handles this part of Unity) should get on fixing it right away. I'm still having an actual hard time believing what the fix is, it's just so random and strange. In short, the solution was to enable my wireless network adapter:

    Good (Unity opens! Praise the heavens!):
    upload_2020-5-22_14-38-37.png

    Bad (Unity cannot open in any way, shape or form):
    upload_2020-5-22_14-38-55.png

    Note that it doesn't even matter if the adapter is connected to a network. The internet still goes through the cable. I can toggle the adapter on or off and 100% reliably cause this issue to reoccur or go away. This is deeply mystifying - what in the world can Unity be doing that cares about this? Most mysterious.

    I will go back to work, meanwhile, and leave the folks at Unity to ponder how in the world this happened.
     
  3. BasilUnity

    BasilUnity

    Unity Technologies

    Joined:
    Mar 28, 2018
    Posts:
    93
    Hello @Tor-Vestergaard

    Thank you for taking the time to share with us your experience, particularly in such a detailed manner. I'm sorry you were blocked: it really sounds frustrating! I appreciate your trust and particularly that you chose to come to us, rather than douse your computer in Holy Water: the results of that alternative could've been... disappointing!

    I'd like to provide you with a short explanation of how licensing works in Unity and hope this will clarify the behaviour you experienced. When your Unity license is issued to you, it is bound to a number of hardware identifiers on your machine. One of those identifiers is the MAC address of your primary network adapter. We prioritise the onboard adapter above else, as it can't be easily disconnected. In your case, given that the onboard adapter was disabled, things broke.

    There is a small utility that is shipped with Unity Hub, which can list the system's network adapters in the order Unity Licensing detects them:
    Code (CSharp):
    1. "C:\Program Files\Unity Hub\resources\app.asar.unpacked\node_modules\@unityhub\unity-editor-license\build\Release\nativetest" -v
    Alternatively, you can run the following in PowerShell:
    Code (CSharp):
    1. Get-WMIObject MSFT_NetAdapter  -Namespace root\StandardCimv2 | select Name,InterfaceDescription,InterfaceOperationalStatus,ConnectorPresent,PermanentAddress,NetworkAddresses,PNPDeviceID
    I understand that in your situation, the exact nature of the problem was never obvious: the messaging in the Hub was cryptic and unhelpful. We've made several improvements to licensing on Windows and the behaviour you've observed here will not happen again as of Unity Hub 2.3.2.

    Thanks again for documenting your findings and have a great week!
     
    Tor-Vestergaard likes this.
  4. chatrat12

    chatrat12

    Joined:
    Jan 21, 2015
    Posts:
    121
    I'm on Unity Hub 2.3.2 and had the same thing happen to me. I tried enabling my Wifi again that didn't work. Then I enabled the adapters for Docker and my VPN. Then it worked. At least I can launch my editor, this was driving me mad xD
     
  5. Asaioki

    Asaioki

    Joined:
    Aug 1, 2016
    Posts:
    43
    Same issue and solution here, thanks to @chatrat12 for bringing me to this thread. Turning on all my adapters allowed me to launch the editor again. Is it possible to remove and add adapters from your license?
     
  6. BasilUnity

    BasilUnity

    Unity Technologies

    Joined:
    Mar 28, 2018
    Posts:
    93
    Hi @sdijkens : As of Hub 2.3.2, the licensing module will automatically detect the active network adapter, even if it's a VPN adapter. Unfortunately these fixes have yet to make it into any of the Unity Editors, which is why the network adapters have to be enabled.

    You can see which network adapter your license is bound to if you open the Unity_lic.ulf file in any text editor. On Windows, it is located inside the
    %PROGRAMDATA%\Unity\
    folder and the MAC address of the network interface will be listed under under
    <Binding Key="5" Value=""/>
     
    Asaioki likes this.
  7. JoshBlain

    JoshBlain

    Joined:
    Oct 29, 2018
    Posts:
    1
    I have the exact same problem but I have tried enabling all adaptors (wifi ethernet, VPN) and it still just returns to Unity Hub after appearing to be launching unity editor. This is on Unity Hub version 2.3.2. I have tried this with the vpn on and off. I am connected via ethernet cable to the internet. PLEASE HELP.
     
  8. ArinSanghi

    ArinSanghi

    Joined:
    Apr 26, 2019
    Posts:
    2
    Can anyone please explain whats the solution of this?