Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Animations aren't working from Mixamo?

Discussion in 'Animation' started by JueixRocks, Nov 17, 2018.

  1. JueixRocks

    JueixRocks

    Joined:
    Feb 10, 2013
    Posts:
    13
  2. JueixRocks

    JueixRocks

    Joined:
    Feb 10, 2013
    Posts:
    13
    anyone can help?
     
  3. leftshoe18

    leftshoe18

    Joined:
    Jul 29, 2017
    Posts:
    61
    Is your character also set up with a humanoid rig?

    Try changing the rig import avatar on the animation to inherit from your character.
     
    MursaatAD likes this.
  4. Lagermeister

    Lagermeister

    Joined:
    May 13, 2017
    Posts:
    16
    I have noted the same problems in Unity 2018.2 . Some times ago importing Mixamo Animation did work. Now it seems that something is broken.

    When i went into "Avatar Configuration" i get now the message " Character is not in T pose".
     
    Last edited: Nov 24, 2018
  5. ComicReese

    ComicReese

    Joined:
    Dec 29, 2016
    Posts:
    10
    Under "Avatar Definition", change it from "Create From This Model" to "Copy From Other Avatar" and set it to the original model's avatar. For you it would be "Playable 1Avatar".
     
  6. dazpants1

    dazpants1

    Joined:
    Mar 30, 2017
    Posts:
    5
    Has there been a fix found for this issue as i an having the exact same issue and also see the "Character is not in T pose" when looking at the avatar. I'm using the Morph3d MCS models. All the Unity Standard Assets animations work fine, and it's just the Mixamo ones i cannot get to work.
     
  7. wirelessdreamer

    wirelessdreamer

    Joined:
    Apr 13, 2016
    Posts:
    128
    I'm seeing the same thing here. I can import the animations fine in a 2018.2 project, but in a 2018.3.3f1 project all mixamo animations now give: Character is not in T Pose
     
  8. ex0r

    ex0r

    Joined:
    Nov 9, 2012
    Posts:
    27
    How did you get them to import in 2018.2? When I attach them to a controller the animations get broken when I play them back .
     
  9. wirelessdreamer

    wirelessdreamer

    Joined:
    Apr 13, 2016
    Posts:
    128
    I got this working yesterday, here's what I did:

    • Download Animation in FBX for Unity format, and without skin
    • Select animation in unity, convert to humanoid rig, and apply
    • On the same page click configure
    • Click on Pose, and then Enforce Tpose
    • Click Apply, then Done
    • Edit the Animation under the fbx and rename the animation name from mixamo.com to a useful animation name
    • Duplicate the animation from the fbx to extract it from the fbx, now you have the animation without the fbx
     
  10. samuellvcpires

    samuellvcpires

    Joined:
    Apr 24, 2017
    Posts:
    1
    that kinda worked for me. The bones and animations got fixed but lost the root motion
     
  11. ComicReese

    ComicReese

    Joined:
    Dec 29, 2016
    Posts:
    10
    Is this Unity’s new way of importing animations now or it’s a bug?
     
    Last edited: Feb 16, 2019
    Ony likes this.
  12. jewelson22

    jewelson22

    Joined:
    Feb 22, 2018
    Posts:
    1
    It's a Bug. Adobe needs to address this issue. I can't seem to fix the animations.
     
  13. Diffins

    Diffins

    Joined:
    Jun 20, 2018
    Posts:
    1
    You can try to change "root motion node" in "motion" in animation import settings on "Root transform" from "None"
     
    Willbkool_FPCS likes this.
  14. Ony

    Ony

    Joined:
    Apr 26, 2009
    Posts:
    1,954
    Animations (not just Mixamo - I'm not using anything from Mixamo but this thread seems relevant) seem to be totally borked in 2018.3.5 and 2018.3.6. I have them working fine in 2018.2.5, with the same import options. By "borked" I mean they are completely hosed. Bones rotated all over the place weirdly, character position hopping everywhere.

    In 3.x I get the "Character is not in T pose" message in the configure options. I've tried both "Enforce T-pose" as well as "Sample Bind-pose" and doing that changes things so they come closer to working, but they are still pretty seriously bugged. The character pops all over the place, no matter what settings I do for root motion (in the character and/or the animations import), and some of the bones are still rotated strangely.

    So for now I'm rolling back to 2018.2.5 since that works fine. I'd like to hear from Unity about this, if they made major changes to the animation system moving forwards, that would be good to know.
     
    Last edited: Feb 28, 2019
    twobob likes this.
  15. ogtracy

    ogtracy

    Joined:
    Sep 27, 2016
    Posts:
    22
    I had this problem. I found out that the animations I downloaded with the same model before the problem started were still fine.
    So, I
    1. download the animations from mixamo "without skin"
    2. under "Rig" I changed the Avatar Definition to "Humanoid" and "Copy from other avatar".
    3. I plugged in an avatar from one of my old downloads into the "Source" field and it worked.
     
  16. idduland

    idduland

    Joined:
    Sep 14, 2018
    Posts:
    3
  17. Sun-Dog

    Sun-Dog

    Joined:
    Mar 23, 2009
    Posts:
    144
    In the end, I opened the animation from Mixamo and configured it by hand:

    I selected configure:
    5f048e7deac97f5f10033a5d83c9f4c0.png

    And then dragged in all of the bones to match:
    bcfabfadf350b7e0fd012e3b32ed2387.png

    The odd bit is that Mixamo has more bones, especially in the hands, than the Unity Rig:
    d97dbca7af61e94f41dfdc6c99eb3b6d.png

    I did have to enforce t-pose in the Pose menu:
    a72906b24df7097ce94a82da2f5ce713.png
     
  18. Sun-Dog

    Sun-Dog

    Joined:
    Mar 23, 2009
    Posts:
    144
    As a word of caution, when I tried to simply enforce T-Pose on an empty (red) rig:
    4caa87c77adada9e9e5908b954cc707d.png

    Unity just crashes:
    2104dacdd625b5f125064e0fc3258d98.png

    So, (as far as I could tell) I had to manually drag in the bones!
     
  19. Sun-Dog

    Sun-Dog

    Joined:
    Mar 23, 2009
    Posts:
    144
    Strangely...

    On a third or fourth try, Automap seems to work now:
    eafdc37bb356a34c06a105a7d5c085b7.png

    It crashed Unity the first few times I tried it.

    FWIW Automap seems to ignore the 4th bone in the hand, whereas I ignored the first when I did it manually:
    b14ca045f45c5af02f11ad364ba29784.png
     
    wetcircuit likes this.
  20. Sun-Dog

    Sun-Dog

    Joined:
    Mar 23, 2009
    Posts:
    144
    So:

    Download without skin:
    1899ad2671d04edf176bbb9d52560611.png

    Configure:
    5f048e7deac97f5f10033a5d83c9f4c0.png

    Automap:
    eafdc37bb356a34c06a105a7d5c085b7.png

    Enforce T-Pose:
    a72906b24df7097ce94a82da2f5ce713.png

    Apply and Done

    You should be good to go.
     
    MadeFromPolygons likes this.
  21. SomeGameDesigner

    SomeGameDesigner

    Joined:
    Mar 8, 2019
    Posts:
    3
    Just sent a bug report and hopefully Unity will do something about this. In Unity 5 all you have to do is import your .fbx animation file and convert to Humanoid. Unity 2018 has problems with this for some reason..

    I literally have Unity 5 installed just to convert animation files to Humanoid properly and then bring it back to Unity 2018.
     
    Ony likes this.
  22. Petitbateau

    Petitbateau

    Joined:
    Jan 28, 2018
    Posts:
    1
    It was exactly the problem, thank you.
     
  23. PandamoniumGameStudios

    PandamoniumGameStudios

    Joined:
    Mar 16, 2017
    Posts:
    2
    this works perfectly! helped a lot. now i just need to rename 39 animations that are mixamo.com lol. Adobe and Unity really should find a workaround for this besides just blaming each other
     
  24. shubh143

    shubh143

    Joined:
    Jun 1, 2017
    Posts:
    7
    hi i am trying to import mixamo animations in my humanoid model but the animation arent working properly
     
  25. Willbkool_FPCS

    Willbkool_FPCS

    Joined:
    Jun 13, 2018
    Posts:
    151
  26. unity_w-ENocDp_xTWtg

    unity_w-ENocDp_xTWtg

    Joined:
    Feb 9, 2018
    Posts:
    1
    copy the T-pose Avatar and replace with other Avatars
     
  27. zedz

    zedz

    Joined:
    Aug 31, 2013
    Posts:
    80
    OK, Ive had a lot of issues
    tried a lot here and in other threads on these forums, which didnt work 100%, I'ld still have dragging legs etc
    But this might help in some cases

    To fix the floating person problem, go to the Model tab, and change the persons scale of the imported animation for some meshes this was enough to fix the floating
     
  28. mbhagat

    mbhagat

    Joined:
    Dec 15, 2013
    Posts:
    28
    Thank You ! It saved my time.
     
  29. Noman007

    Noman007

    Joined:
    Apr 10, 2017
    Posts:
    1
    i did all the above things they was not working for me.
    what i did is :
    1) downloaded the Animation (walking) without skin.
    2) downloaded a ybot character of mixamo in T_pose.
    3) assigned the animation to The ybot Character in Maya.
    4) exported the animation with skin and it solved the issue

    when iam exporting the animation without skin i face the same issue.

    Solution :
    export the animation with skin and use it.

    iam using unity 2018.3 and it is also working in unity 2019.2.8
     

    Attached Files:

  30. ShadYueh

    ShadYueh

    Joined:
    May 31, 2014
    Posts:
    2
    Yea, that is what worked to me. Saved me headaches.
    I'm using unity 2019.4.1f1
     
  31. Renan-Reis

    Renan-Reis

    Joined:
    Dec 9, 2012
    Posts:
    7
    1) Import the mixamo animation to Unity 2017
    2) Convert the animation to humanoid
    3) Export the animation as unitypackage
    4) Import the unitypackage into higher versions of Unity
     
unityunity