Search Unity

  1. Looking for a job or to hire someone for a project? Check out the re-opened job forums.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Animation Import (Mixamo) Odd leg...

Discussion in 'Animation' started by Ruffian0305, Feb 21, 2018.

  1. Ruffian0305

    Ruffian0305

    Joined:
    Feb 23, 2015
    Posts:
    1
    Hello! I have worked a bit with animations and mixamo before, but this is the first time I have had this particular problem and I can not crack it.

    I have tried using a custom model, a mixamo model, and the unity guy and the results are the same.

    Onto the problem:
    I have a model (in this case, Unity Guy will be a good example) that is rigged proper and such, as well as a Mixamo animation (in this case a simple running animation).

    (Full album here: https://imgur.com/gallery/N8qcr )

    My Mixamo animation rig: (https://i.imgur.com/kulea6k.png)
    My characters rig: (https://imgur.com/rrdD0gM)
    *Note: The unity guy rig, as well as a Mixamo rigged character produces the same results

    The rigs look okay, everything seems to match up, mooooving on....

    Let's look at a walking animation:
    Unity Guy Walking: (https://imgur.com/kcPhdgx)
    Barbarian Walking: (https://imgur.com/xX2ZOAD) Note: I know he is huge, I am not sure why, another problem for another day it seems

    Walking looks good, lets try to run!
    Unity Guy Running: (https://imgur.com/71t4TXR)
    Barbarian Running: (https://imgur.com/e2rhHKn)

    Say what now? That left foot looks great!

    I am not sure what is happening, why it is happening ... It happens with every animation (I did a lot of tweaking to get the walk to look halfway decent, changed some bones ... but it doesnt help when every other animation is broken and I can't change the rig per animation). Right foot is fine, left foot hates the world. And when it runs it just kind of ragdolls around the "ankle" and looks terrible.

    I am at a loss with this one, and I really hope someone else has seen/encountered this and knows a way I might be able to fix it!

    The animations I am using can be downloaded
    here (walk): https://www.mixamo.com/#/?page=1&query=male+brutal+walk
    and here (run): https://www.mixamo.com/#/?page=1&query=running+forward+quickly
    if you wanted to check for yourself.
     
    Dflow likes this.
  2. theANMATOR2b

    theANMATOR2b

    Joined:
    Jul 12, 2014
    Posts:
    7,786
    I saw this before - someone was having the same issue with a blender imported animation. Consider looking back through the animation sub-forum.
    I cant remember the solution but a couple thoughts.
    Check the avatar applied to the animations. Might want them to match the character avatar the anims are being retargetted onto.

    Double check the T pose settings. Check to see if enforcing T pose helps.
     
  3. midiman

    midiman

    Joined:
    Jan 11, 2014
    Posts:
    1
    Not sure if you still have this issue but as there was no solution posted, I wanted to leave a possible solution for others encountering the same weirdness. I ran into the exact same issue importing some mixamo animations. For whatever reason, the following fixed the weird bendy leg issue for me. From mixamo , download the animation with skin (I used one of the robot guys). Import into unity. View the animation and make sure it is previewed with the skin you downloaded with the mixamo animation (if not, drag the downloaded fbx to the preview window to change it). It should play correctly in the preview. Switch rig to humanoid and then switch the animation target to your own character. The weird leg problems with certain animations went away after that process though I have no idea why that fixed things.
     
  4. DMariscal

    DMariscal

    Joined:
    Feb 2, 2017
    Posts:
    5
    I was having the same issue and just came across your comment, it also fixed my issues importing animations from mixamo, thanks for taking the time to post your solution!
     
  5. MaximumTre

    MaximumTre

    Joined:
    Nov 28, 2015
    Posts:
    156
    You can also use the UMotion animation asset to fix Mixamo's buggy animations. The free version works just fine for these purposes, but I'd suggest buying the pro-version if you can, as it's a powerful animation tool imo.
     
  6. JotaRata

    JotaRata

    Joined:
    Dec 8, 2014
    Posts:
    46
    I have a fix. I had an issue where the legs animations were moving oddly, and that made the character to move super weird ( the feet were twisted, the legs passed thru each other, etc).
    My solution is:
    1. Make a copy of an idle model
    2. Assign a humanoid rig, and choose Create for this model.
    3. Rename the object something like Player Rig
    4. Take all your other animations, and set the Rig to humanoid and then choose Copy form model
    5. Now select your Player Rig model as the Rig of the other animations..
    Here's where the fun begins..
    1. Open the Player Rig model in Cinema 4D or something.
    2. Set all bones rotations to zero ( relative to its parent of course ) That would make your model into a perfect T-Pose
    3. Back to Unity edit the Player Rig avatar, and then go to Pose > Enforce T-Pose.
    4. Select all your animations, go to Rig and click the Update button.
    5. Done, all your animation issues should be fixed, for now..
    I'm posting this here because i'm too lazy to post a new thread

    Oh, if something goes wrong, try going to Muscles & Settings tab in the Avatar editor, and change feet space, and/or leg twist values

    And the last thing, is quite annoying but Cinema4D changes the colon of the Mixamo:Hips bones into underscores like Mixamo_Hips. That would break the rigging, if you edit a mixamo model using Cinema4D make sure to re-export all you other stuff too, thus all the bone will have the same name ( and the rigging will work)
     
    Last edited: Jul 4, 2018
  7. CosmicBoy

    CosmicBoy

    Joined:
    Apr 16, 2014
    Posts:
    33
    A solution that worked for me at the end of this thread https://forum.unity.com/threads/fuse-mixamo-animation-problem.491967/

    Download the T-Pose animation and model from Maximo, set the avatar to Humanoid and Configure the Avatars bones. Then set all other Maximo models with animations to copy from the Avatar of the T-Pose model, then those animations will work on other Avatars correctly.
     
  8. joeyether40

    joeyether40

    Joined:
    Jan 26, 2018
    Posts:
    20
    Ty this worked great. I have almost given up on mixamo for those odd walks.
     
  9. ridley1224

    ridley1224

    Joined:
    May 28, 2014
    Posts:
    4
    In the configure avatar definition screen, clicking "Enforce T-Pose" worked for correcting my mixamo animations.

    Screen Shot 2019-08-20 at 1.58.01 PM.png
     
  10. mrochefort12v

    mrochefort12v

    Joined:
    Oct 7, 2018
    Posts:
    2

    Thanks! That solved my wobbly leg problem.
     
  11. Damiano96

    Damiano96

    Joined:
    Sep 16, 2019
    Posts:
    4
    Life saver, my model has been running around looking like he has two broken legs for a week! Thankyou! :)
     
  12. Treecrotch

    Treecrotch

    Joined:
    Dec 30, 2019
    Posts:
    212
    Thanks, mixamo broken leg is fixed !!!
     
    xjjon likes this.
  13. granit

    granit

    Joined:
    Jan 18, 2013
    Posts:
    4
    Thank you! Worked like a charm. :)
     
  14. Twist-Games

    Twist-Games

    Joined:
    Jan 23, 2020
    Posts:
    7
    I know this is an old topic, but for others who also has this problem, it worked for me, to go on to the import settings of the animation & make sure its humanoid. Then chnaging the avatar definition to "Copy from other Avater". Then i selected my own avatar, & then it worked just fine :)
    upload_2020-8-14_15-20-30.png
     
    ROBYER1 likes this.
  15. peaceamit

    peaceamit

    Joined:
    Jul 18, 2015
    Posts:
    2
    Though it is an old thread, for everyone's help here is additional option that worked for me. :)

    Ensure you have T-pose for Mixamo model and configure rig as humanoid. For all other animations, ensure you copy rig from the T-pose model. That way, the animations will not have the twisted legs.
     
  16. kumarsatyam17

    kumarsatyam17

    Joined:
    Jul 29, 2020
    Posts:
    2
    In the Rig tab of every animation, you can set the Animation type as Legacy to fix that problem of weird leg animations. It had worked for me so far.
     
  17. kumarsatyam17

    kumarsatyam17

    Joined:
    Jul 29, 2020
    Posts:
    2

    Works pretty fine Thanks a lot !!
     
unityunity