Search Unity

After Making "Start Game" button; Games color is off

Discussion in 'Scripting' started by j_spencer93, Nov 6, 2018.

  1. j_spencer93

    j_spencer93

    Joined:
    Dec 17, 2015
    Posts:
    60
    I am not sure if it has to do with the coding or not, but I am having an issue that I can't seem to fix. If this isn't the right place to post this then please point me in the right direction.

    After making the Main Menu scene with a working start game button, once it is clicked, the game loads all washed out. Below are the two images. I am assuming it has to do with a material or something from the start screen. Screen Shot 2018-11-06 at 3.21.33 PM.png Screen Shot 2018-11-06 at 3.21.19 PM.png

    The coding is straight from a tutorial that i have used before without any errors:

    using System.Collections;
    using System.Collections.Generic;
    using UnityEngine;
    using UnityEngine.SceneManagement;

    public class MainMenu : MonoBehaviour {

    public void PlayGame()
    {
    SceneManager.LoadScene(SceneManager.GetActiveScene().buildIndex + 1);
    }

    public void QuitGame ()
    {
    Debug.Log("Quit!");
    Application.Quit();
    }
    }
     
    Last edited: Nov 6, 2018
  2. j_spencer93

    j_spencer93

    Joined:
    Dec 17, 2015
    Posts:
    60
    NVM it is fixed now.
     
  3. Lurking-Ninja

    Lurking-Ninja

    Joined:
    Jan 20, 2015
    Posts:
    4,273
    It's always mandatory to post your code in code tags in the forum, also it is courteous if you include your solution for the record: if someone searches the forum and have similar issue.
     
    Kiwasi and SparrowsNest like this.
  4. SparrowsNest

    SparrowsNest

    Joined:
    Apr 6, 2017
    Posts:
    1,837
    I too am wondering what's up with that?

    a wild guess is you spawn another light in there with the scene, but as ninja said, include you solution so others can know
     
  5. j_spencer93

    j_spencer93

    Joined:
    Dec 17, 2015
    Posts:
    60
    I apologize for that. And the solution was, you have to go to Windows - Rendering - Lighting settings and turn the auto generate off on one of the scenes.