Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
Dismiss Notice
Join us now in the Performance Profiling Dev Blitz Day 2023 - Q&A forum where you can connect with our teams behind the Memory and CPU Profilers and the Frame Debugger.

[XR][MR][VR] Playing in editor not showing the scene after build

Discussion in 'VR' started by Fahim_Ahmed, Dec 28, 2017.

  1. Fahim_Ahmed

    Fahim_Ahmed

    Joined:
    Mar 8, 2014
    Posts:
    10
    1. Create new project
    2. Apply necessary settings for XR development.
    3. Open an example or any scene with proper prefabs and settings.
    4. Play -> Works fine. I can see my scene in HMD display as well as in Mixed Reality Portal window.

    5. Save and build the scene using Build tools from HoloToolkit.
    6. Open solution in VS2017
    7. Switch to x64 configuration.
    8. Run "Start debugging" -> Works fine. I can see my unity scene in HMD display as well as in Mixed Reality Portal window.

    9. Back to Unity and hit play -> Nothing in MR Portal. I can see headset is tracking and camera is moving in editor but nothing in HMD display or in MR Portal.
    HMD display and MR Portal is showing the default scene of MR Portal, not the Unity scene.



    I tried,

    • Unity 2017.2.0p4, 2017.2.1f1, 2017.3.0p1
    • HoloToolkit-Unity-2017.2.1.0
    • HoloToolkit-Unity-Examples-2017.2.1.0
     
  2. Unity_Wesley

    Unity_Wesley

    Unity Technologies

    Joined:
    Sep 17, 2015
    Posts:
    558
    Hello,

    Is the scene included in the build settings?
     
  3. Fahim_Ahmed

    Fahim_Ahmed

    Joined:
    Mar 8, 2014
    Posts:
    10
    Yes and I can run any unity project properly.

    "8. Run "Start debugging" -> Works fine. I can see my unity scene in HMD display as well as in Mixed Reality Portal window."
    Problem start after I build and run any project. Playing the scene in editor not appear in MR Portal as well as in HMD display. But if I build and run using VS2017, it works fine.
     
  4. Unity_Wesley

    Unity_Wesley

    Unity Technologies

    Joined:
    Sep 17, 2015
    Posts:
    558
    Sounds like the issue with the MR Portal.

    Can you file a bug with a min repro project and repro steps so we can further investigate to make sure there is not an issue on the unity side?

    Thank you
     
  5. Fahim_Ahmed

    Fahim_Ahmed

    Joined:
    Mar 8, 2014
    Posts:
    10
    Sample Project Link

    Steps of reproduce:
    1. Fresh install Unity.
    2. Create new project. (Do not import old projects.)
    3. Import HoloToolkit.
    4. Apply MR settings.
    5. Run a MR sample scene.
    6. Hit play. (Works fine)
    7. Build using HoloToolkit.
    8. Hit Play again. (Not working now.)
    If you create any new project now, it will not work properly in Unity editor. To make it works again, you have to reinstall Unity and create a new project again.


    Current system info:

    Windows 10 Pro. Build 16299
    Unity 2017.3.0p1
    VS 2017 (Win SDK 10.0.16299)
    Processor Core i7 6700k
    Nvidia GTX 1080
    RAM 32GB
     

    Attached Files: