Search Unity

xCode problem running on external SSD

Discussion in 'iOS and tvOS' started by areavisuale, Feb 20, 2019.

  1. areavisuale

    areavisuale

    Joined:
    Jul 23, 2015
    Posts:
    44
    Hi community!

    The last week I encountered a problem with xCode 10.1 (also with 10.0 and the last beta), and after hours of testing I can confirm that is related to the installation of OSX in an external SSD.



    I have an iMac 21' 2017 i5 3ghz 8gb ram with 2gb radeon graphic card.

    I installed OSX Mojave in an external Samsung T5 500gb SSD through USB Type C (APFS partition format)



    When I tried to verify/upload a simple Unity3D empty project that I had succesfully built and then created the archive in the organizer, xCode freezes on the "fetching app store" window, and after 20-30 minutes my iMac crashes.

    The only way I found to avoid this is to create the archive without armv7 architecture support.



    So I booted my iMac in my internal HDD partition instead of the external SSD (both OSX are up-to-date, and have the same configuarations), and I tried to verify the archive. It works! I was able to verify the archive also in my MacBook Pro 2011 with High Sierra - xCode 10.1.


    So the problem seems to be related to a difficulty of the SSD. Anyone are experiencing the same problems? Do you know a workaround??


    Thanks