Search Unity

  1. We've closed the job boards. If you're looking for work, or looking to hire check out Unity Connect. You can see more information here.
    Dismiss Notice
  2. We're running great holiday deals on subscriptions, swag and Asset Store packages! Take a peek at this blog for more information!
    Dismiss Notice
  3. Check out our Unite Austin 2017 YouTube playlist to catch up on what you missed. More videos coming soon.
    Dismiss Notice
  4. Unity 2017.2 is now released.
    Dismiss Notice
  5. The Unity Gear Store is here to help you look great at your next meetup, user group or conference. With all new Unity apparel, stickers and more!
    Dismiss Notice
  6. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  7. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice
  8. Unity 2017.3 beta is now available for download.
    Dismiss Notice

[xcode] clang: error: unable to execute command: Segmentation fault: 11

Discussion in 'Unity Cloud Build' started by SniperED007, Sep 20, 2016.

  1. SniperED007

    SniperED007

    Joined:
    Sep 29, 2013
    Posts:
    48
    I keep getting the following errors on iOS Cloud Build, my project used to build successfully and if I do a manual build to my phone (instead of a cloud build) it works without errors.

    Any ideas what this could be caused by?

    14379: [xcode] clang: error: unable to execute command: Segmentation fault: 11
    14380: [xcode] clang: error: linker command failed due to signal (use -v to see invocation)
    14381: [xcode] ** BUILD FAILED **
     
  2. dannyd

    dannyd

    Unity Technologies

    Joined:
    Jun 3, 2014
    Posts:
    667
    Which version of Unity and Xcode do you have selected for that build target? The first thing I would try is manually selecting Xcode 7.3
     
  3. SniperED007

    SniperED007

    Joined:
    Sep 29, 2013
    Posts:
    48
    Unity 5.4.1p1

    I'll try manually selecting Xcode 7.3 now and try again
     
  4. SniperED007

    SniperED007

    Joined:
    Sep 29, 2013
    Posts:
    48
    Thanks, that worked! Interesting that it was that as it was set to use the latest version of Xcode which is 7.3 according to the dropdown list.
     
  5. dannyd

    dannyd

    Unity Technologies

    Joined:
    Jun 3, 2014
    Posts:
    667
    Great! And ya, we are in the process of updating of updating which version "latest" is (current it's 7.2).
     
  6. enghoff

    enghoff

    Joined:
    Jun 12, 2015
    Posts:
    4
    I am having this exact problem when building using the iOS Cloud Build service (but not on an independent workstation). How do I specify the Xcode version for a Cloud Build?
     
  7. SniperED007

    SniperED007

    Joined:
    Sep 29, 2013
    Posts:
    48
    select the CONFIG tab from the build.cloud.unity3d.com website page of your game, then open the "Show Signing Credentials" under your iOS settings. And edit the Xcode Version to select Xcode 7.3
     
    enghoff likes this.
  8. Neonlyte

    Neonlyte

    Joined:
    Oct 17, 2013
    Posts:
    38
    Just subscribed to this thread for future updates. :p
    I was trying to get an iOS build on Cloud Build with 5.4.f1, but I assumed that the "Use latest Xcode version" means Xcode 8.
    I switched to Xcode 7.3 in config, but the webpage showed that my Unity version choice is not compatible with the Xcode version I chose. Is it safe to ignore this for now?
     
  9. enghoff

    enghoff

    Joined:
    Jun 12, 2015
    Posts:
    4
    Thank you, found it!