Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on Dec 8, 2022, between 7 am & 7 pm EST, in the DOTS Dev Blitz Day 2022 - Q&A forum, Discord, and Unity3D Subreddit to learn more about DOTS directly from the Unity Developers.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Bug Wrong Particle Force Field behaviour

Discussion in 'General Graphics' started by novaVision, Feb 24, 2022.

  1. novaVision

    novaVision

    Joined:
    Nov 9, 2014
    Posts:
    421
    There was a known bug in 2021.2.x, which was finally "fixed" in 2021.2.12.
    I have updated the project and was almost happy to see it works, but... It still doesn't work as expected.
    The problem is, that settings up particles and force fields parameters in Edit mode, I realized that in Play mode and on the mobile device build it looks different.

    You can compare it:
    1. Edit mode
    2. Play mode

    Force fields settings
    Attaching example scene.

    Looks like y direction force affects much stronger to particles in Play Mode. There are some other issues as well (not only that direction problem).

    Please check that bug - the only way to setup the correct particles + force fields settings is to Play the scene and adjust it runtime what is really uncomfortable approach. But even doing so, the result isn't always the same
     

    Attached Files: