Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Question World Space button non-interactable; HDRP & Input System

Discussion in 'UGUI & TextMesh Pro' started by BenjaminApprill, Dec 16, 2022.

  1. BenjaminApprill

    BenjaminApprill

    Joined:
    Aug 1, 2022
    Posts:
    128
    Hey what's up!

    I have a project that I decided to build using UI Toolkit and UI Elements... However, upon needing text in world space, I discovered that UI Toolkit does not support world space elements yet.

    Therefore, I tried creating a world space canvas with a button to solve this problem... I am now running into an issue where the button is non-interactable. I have looked at other threads, and have tried about a dozen proposed solutions that have worked for others... The button is still non-responsive.

    If I switch the canvas to use 'Screen Space - Overlay' the button works as intended. It seems to be some kind of issue with having a world space canvas in particular.

    I've tried many solutions, such as the ones posted in threads like this - https://forum.unity.com/threads/gui-button-doesnt-work-in-world-space.265048/

    My best guess is that there is some kind of interference between the new UI Toolkit, Input System, and the legacy Unity UI. Any help on this will be greatly appreciated...
     
    unity_Jf-tNyrJq-Wctw likes this.