Search Unity

Resolved WMR, HP Reverb G2, URP - bright blue border when post-processing is enabled

Discussion in 'VR' started by Doc_Martins, Mar 7, 2023.

  1. Doc_Martins


    Jun 1, 2020
    Unity 2021.3.9f1, URP 12.1.7, (Microsoft) Mixed Reality OpenXR Plugin 1.7.0

    While trying out a darker scene in URP with Post-Processing on a Windows Mixed Reality headset (HP Reverb G2) I noticed a blue border around the image. Looking into the lens, I can see that the blue border seems to be part of the background of the actual stereo rendering on the headset's screen (or screens). The image attached is a rough sketch to convey my meaning.

    [Edited] TL;DR Solution: By experimenting, I managed the following solution: in the Main Camera, Camera component, Environment settings, set the Background Type to "Solid Color", choose black; then revert the Background Type to "Skybox". Not sure if this is a bug per se or a reasonable "side-effect", but it was somewhat unexpected and did not occur on other platforms (or with Post-Processing disabled). Disabling HDR or switching rendering mode (to multi-pass) did not solve the issue. I'll leave the rest of the original post below for reference.


    Experimenting, I found that this disappears (or is rendered black, perhaps) if I disable "Post Processing" in the Main Camera. I also tried leaving "Post Processing" enabled the Main Camera and alternately deactivating the Post Processing volume, and any of the overrides, but the blue border/background persists in any case.

    I tried running the same setup with the Reverb G2 in Steam VR, by setting "Play Mode OpenXR Runtime" explicitly to "Steam VR". The blue border persists. I'm guessing in any case that even though the Steam VR splash screen does show up, the rendering is still mediated through Windows Mixed Reality.
    I also tried out the same project on a different machine with an HTC Vive Pro running on Steam VR, and can confirm that the blue border does not appear in this case.

    If anyone has any suggestion or tips, or ran into similar issues, all feedback is welcome.
    I am guessing this may be an issue with WMR, but since it seems to be somehow influenced by the Post-Processing option in Unity I am hoping it can somehow be solved from within the editor.

    I have not tried to build and run the project.
    The project is based on the XRIT example project, and uses the same URP Asset.
    I will experiment with disabling HDR or using Single-Pass Instanced rendering; and other options that I can find.
    Last edited: Mar 7, 2023
    Daminocado likes this.