Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Bug Windows11 install_failed : Validation Faild

Discussion in 'Unity Hub' started by bai_nian_lao_yao, Dec 4, 2023.

  1. bai_nian_lao_yao

    bai_nian_lao_yao

    Joined:
    Aug 2, 2022
    Posts:
    2
    system: Windows 11 pro 22h2
    unity hub: 3.6.1
    install editor: 2022.3.13f1c1
    bug:
    install of editor will show uac interface, after click confirm, it will still fail, log is:
    Code (JavaScript):
    1. {"timestamp":"2023-12-04T00:42:51.262Z","level":"info","moduleName":"Installation Manager","message":"[ 'Starting installer of 2022.3.13f1c1-x86_64' ]"}
    2. {"timestamp":"2023-12-04T00:42:51.262Z","level":"info","moduleName":"Installer: 2022.3.13f1c1-x86_64","message":"[ 'Retrying the installation of 2022.3.13f1c1-x86_64.' ]"}
    3. {"timestamp":"2023-12-04T00:42:51.262Z","level":"info","moduleName":"Installer: 2022.3.13f1c1-x86_64","message":"[ 'Exiting from State: Failed. Event: RETRY' ]"}
    4. {"timestamp":"2023-12-04T00:42:51.262Z","level":"info","moduleName":"Installer: 2022.3.13f1c1-x86_64","message":"[ 'Transition to state \"install_validation\" on event \"RETRY\"' ]"}
    5. {"timestamp":"2023-12-04T00:42:51.263Z","level":"info","moduleName":"Installer: 2022.3.13f1c1-x86_64","message":"[ 'Entered State: install_validation' ]"}
    6. {"timestamp":"2023-12-04T00:42:51.265Z","level":"info","moduleName":"UnityIPCServer","message":"[ 'IPC Server Unity-hubInstallServer started' ]"}
    7. {"timestamp":"2023-12-04T00:42:51.265Z","level":"info","moduleName":"UnityInstallerWindows","message":"[ 'spawn child process, elevated:', true ]"}
    8. {"timestamp":"2023-12-04T00:42:51.265Z","level":"info","moduleName":"UnityInstallerWindows","message":"[ 'executing', '\"C:\\\\Program Files\\\\Unity Hub\\\\Unity Hub.exe\"', '-- --winInstaller' ]"}
    9. {"timestamp":"2023-12-04T00:42:53.400Z","level":"info","moduleName":"UnityInstallerWindows","message":"[ 'user did not agree to the UAC prompt and the process was not started' ]"}
    10. {"timestamp":"2023-12-04T00:42:53.400Z","level":"info","moduleName":"UnityIPCServer","message":"[ 'IPC server Unity-hubInstallServer closed' ]"}
    11. {"timestamp":"2023-12-04T00:42:53.400Z","level":"error","moduleName":"UnityInstallerWindows","message":"[ { code: 'User did not grant permission.', message: 'The Hub does not have proper permissions to install Unity.' }, undefined ]"}
    12. {"timestamp":"2023-12-04T00:42:53.401Z","level":"info","moduleName":"Installer: 2022.3.13f1c1-x86_64","message":"[ 'Validation FAILED.' ]"}
    13. {"timestamp":"2023-12-04T00:42:53.401Z","level":"info","moduleName":"Installer: 2022.3.13f1c1-x86_64","message":"[ 'Exiting from State: Validation. Event: ERROR' ]"}
    14. {"timestamp":"2023-12-04T00:42:53.401Z","level":"info","moduleName":"Installer: 2022.3.13f1c1-x86_64","message":"[ 'Transition to state \"install_failed\" on event \"ERROR\"' ]"}
    15. {"timestamp":"2023-12-04T00:42:53.401Z","level":"info","moduleName":"Installation Manager","message":"[ 'Update: install_failed' ]"}
    16. {"timestamp":"2023-12-04T00:42:53.401Z","level":"info","moduleName":"Installer: 2022.3.13f1c1-x86_64","message":"[ 'Entered State: install_failed' ]"}
    17.  
    what i try:

    consider of install command use cmd.exe, I let cmd.exe always run as admin[not working]
    let unity hub.exe run as admin[not working]

    use old version of unity hub3.2 to install, this is work, but unity hub always update.
     
  2. Thygrrr

    Thygrrr

    Joined:
    Sep 23, 2013
    Posts:
    705
    Same here, since about late July this year. You have to get the downloader manually (sometimes you can find it already downloaded in your Unity Downloads folder), and install it yourself, then manually locate the Editor in hub to be able to use it. You cannot use Hub to add modules to it, either.

    Completely inacceptable and frankly, quite embarrassing this isn't ringing all the alarm bells at Unity. The impact seems to be statistically significant.

    Also, what justifies the existence of Unity Hub now if it can't even install the product on its own for a considerable portion of its users?

    Edition: Windows 11 Pro
    Version: 23H2
    Installed on: ‎05.‎10.‎2022
    OS build: 22631.2787
    Experience: Windows Feature Experience Pack 1000.22681.1000.0

    All editor versions are affected. Hub just can't display the UAC prompt for the main editor installer anymore and quietly fails. (ironically, I can still add/remove modules to older installs).

    Unity must roll back whatever they did to the code that invokes the main installer. It's clearly using the wrong command / experience.

    In the other thread about this, I have done extensive tries with the local security policy (which was still set to mostly default for me), and no combination of UAC settings will make the install happen - possibly turning off UAC might work, but that is more work and a completely different operational Risk than just manually downloading the editor.

    I also couldn't do this even if I wanted on my Work system, which is managed with MS InTune. And I'm not willing to do this on my home system for an installer that has worked with every hub version until whatever was rolled out in July.
     
    Last edited: Dec 8, 2023
  3. Thygrrr

    Thygrrr

    Joined:
    Sep 23, 2013
    Posts:
    705
    Unity_Hub_ovD1zmqCiv.png

    Still broken in 3.7.0-beta.1
     
  4. bai_nian_lao_yao

    bai_nian_lao_yao

    Joined:
    Aug 2, 2022
    Posts:
    2
    Here is some new update and info:
    In editor, when I tyring to open c# file, after accept when UAC window pop out, error occur:
    upload_2023-12-11_9-4-42.png
    which mean code.exe not have enough permission.

    However, when I run the same cmd manually:
    upload_2023-12-11_9-5-11.png
    after I accept UAC again, everything is work fine!

    there is a common between install editor and lunch code.exe, they both use command to run, and after I accept UAC, they looks not get permission anyway. when I use powershell to manually run install command, it work fine too, although there is some other magic process Hub need to do that stop me run "-- --wininstall" to compelete installation.

    the conclusion is, unity seems use wrong way to run command in specific os, can anybody from unity tell us what difference between the way Unity Hub run cmd in Hub 3.2 and 3.6, because at least install in Hub 3.2 is OK.

    ps:
    somehow, if editor run as admin, there is no permission error, it prove the issue is right on permission problem
     
    Last edited: Dec 20, 2023