Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Windows Webplayer Crashes

Discussion in 'Editor & General Support' started by marty, Apr 4, 2006.

  1. marty

    marty

    Joined:
    Apr 27, 2005
    Posts:
    1,170
    I've seen the Windows webplayer crash Explorer while loading, without a Bug Report dialog afterwards, on several machines. One just today, in fact. Is there anything I can submit when this happens?
     
  2. dho

    dho

    Joined:
    Jul 25, 2005
    Posts:
    14
    Happened to me twice as well.

    Although It is quite possible that it crashed simply due to my own code and the fact that windows isn't as forgiving as os x.

    I will investigate tomorow
     
  3. socksy

    socksy

    Joined:
    May 21, 2005
    Posts:
    244
    This hasn't been happening to me since Aras sent me that beta build in an email.
     
  4. marty

    marty

    Joined:
    Apr 27, 2005
    Posts:
    1,170
    I'm almost certain that it can't be my code, as (1) my test applet is relatively simple and (2) it works fine on several other Windows systems.

    In fact, the Unity applet doesn't even appear to get completely loaded, as Explorer "crashes" while the splash screen progress bar is only partway done.

    Is there a new build of the Windows web player available yet?
     
  5. Aras

    Aras

    Unity Technologies

    Joined:
    Nov 7, 2005
    Posts:
    4,537
    D'oh! Nobody updated the web player beta with 1.2.2 release, so it was still linking to the 1.2.2RC3 one.

    Now the web player beta thread links to player which corresponds to 1.2.2 release; and it has a couple of issues fixed. Try downloading it again and checking if it works.

    As for the bug reports: at the moment use bug Unity's bug reporter application (from mac), or just send mail to bugs at otee dot dk. I'll add the bug reporting capabilities in the next web player beta update.
     
  6. marty

    marty

    Joined:
    Apr 27, 2005
    Posts:
    1,170
    Still crashing away.

    It's very inconsistent too. Some systems love the Windows webplayer and other crash while loading applet data. And the crashes are outright - Explorer just disappears and no Unity Bug App comes up.

    So far, in my experience more than half of the Windows systems I have tested on do this.
     
  7. jeremyace

    jeremyace

    Joined:
    Oct 12, 2005
    Posts:
    1,661
    Happened here too.

    WinXP SP2
    AMD Athlon XP 3200+
    1 gig of ram
    Internet Explorer 6.0
    ATI Radeon 9800 PRO 128mb

    -Jeremy
     
  8. guategeek_legacy

    guategeek_legacy

    Joined:
    Jun 22, 2005
    Posts:
    659
    Just had a friend test my fire particle test. None of the particles had textures and he has a 128 MB card so its obviously not texture size problems. Jeff
     

    Attached Files:

  9. klindeman

    klindeman

    Joined:
    Jun 13, 2005
    Posts:
    295
    Looks like a problem with the shaders.

    A while back a friends intel integrated had a problem with a certain otee supplied shader, but it was fixed a while back in one of their changes to them.
     
  10. Aras

    Aras

    Unity Technologies

    Joined:
    Nov 7, 2005
    Posts:
    4,537
    Do you know the model of the video card?
     
  11. guategeek_legacy

    guategeek_legacy

    Joined:
    Jun 22, 2005
    Posts:
    659
    Will find out for you. Jeff