Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We’re making changes to the Unity Runtime Fee pricing policy that we announced on September 12th. Access our latest thread for more information!
    Dismiss Notice
  3. Dismiss Notice

Bug (Windows) Open URL:unityhub does not work

Discussion in 'Unity Hub' started by carmine, Dec 26, 2022.

  1. carmine


    Jan 4, 2012
    (I've used Unity/Unity Hub for years). I am installing it on Windows (running inside Parallels). I have never had this issue before.

    When I open Unity Hub it wants me to Sign in or create an account.
    When I click Sign in, it launches Chrome to the page. I login without issue. Then it prompts me with: Open URL:unityhub (which I assume is to make it run Unity Hub and pass some argument to it).

    It basically just sits at the browser. It does not switch to Unity Hub. I've also tried closing Unity Hub and hitting the link as well as allowing "Always open" (and resetting Chrome and not doing that too).

    It is just not running/passing the information to Unity Hub.

    I also tried some registry key thing I saw on some help websites but that did not work either.