Search Unity

Windows MR Single Pass View Upside Down - 2018.0.2b7

Discussion in 'Windows Mixed Reality' started by Codyn6263, Jun 9, 2018.

  1. Codyn6263

    Codyn6263

    Joined:
    Nov 23, 2016
    Posts:
    6
    I'm trying to work on a VR game in 2018.0.2b7 so i can use shadergraph since i don't know shader code, i'm currently using a Samsung Odyssey, i'm aware that, using the Lightweight Render Pipeline, i can't use multipass which i guess the headset needs, when i use these two in conjunction, i just get a black screen, when i switch over to single pass, the view is upside down and when i tilt down, the view tilts upwards, it's quite weird. I have the windows mixed reality package from the manager, but it didn't do anything. I can use OpenVR and it works just fine, but i'd prefer not to since the way i track my MR controllers doesn't work using OpenVR and i'm not sure how to update it to do so. Any idea how to fix this? Or even if there is a fix? I'm going crazy over here.
     
  2. JasonCostanza

    JasonCostanza

    Unity Technologies

    Joined:
    May 23, 2017
    Posts:
    295
    There is a known issue around MSAA and HDR that we are working on fixing which causes the world to flip like you describe. I don't have an estimate when the fix will land just yet, but disabling one of those two settings tends to resolve the issue. I'd start with taking off HDR.

    Sorry for the trouble it's causing, it is drives us crazy too o_O
     
  3. Codyn6263

    Codyn6263

    Joined:
    Nov 23, 2016
    Posts:
    6
    Ok thanks for the response, sorry for the late response myself i've been away all week, i was starting to wonder whether anyone had even an idea on a fix for this, i'll try what you said, thanks a ton!!
     
  4. Codyn6263

    Codyn6263

    Joined:
    Nov 23, 2016
    Posts:
    6
    Ok so while i was gone, shadergraph as well as the LWRP got an update and now the problem is fixed, i didn't even have to disable MSAA or HDR, thank the heavens!
     
  5. Codyn6263

    Codyn6263

    Joined:
    Nov 23, 2016
    Posts:
    6
    Scratch that, HDR was disabled by default in a new project in the quality settings, after turning it back on, i ran into the same issue, so disable HDR in the quality settings to fix it, if it's not in the quality settings (because your using the light weight render pipeline) find your LWRP asset in the asset browser and click it to change it's settings, and disable HDR through that
     
    JasonCostanza likes this.
  6. Tom-Goethals

    Tom-Goethals

    Joined:
    Mar 6, 2015
    Posts:
    80
    Still an issue in 2018.3.8, is there an issue tracker ticket i can vote on somewhere?
     
  7. JasonCostanza

    JasonCostanza

    Unity Technologies

    Joined:
    May 23, 2017
    Posts:
    295
  8. Tom-Goethals

    Tom-Goethals

    Joined:
    Mar 6, 2015
    Posts:
    80
    Well, the bug is not mentioning Window MR specifically.. we'd need to do some tests to see if Oculus is experiencing the same thing, but i doubt it will. Disabling MSAA fixes it for now..
     
  9. JasonCostanza

    JasonCostanza

    Unity Technologies

    Joined:
    May 23, 2017
    Posts:
    295
    I would assume if it's MSAA related then this will be a global issue between all the VR headsets but i'll make note to our engineer to check WMR as well.
     
  10. Benjams

    Benjams

    Unity Technologies

    Joined:
    Oct 27, 2017
    Posts:
    13
    We were able to reproduce this issue in 2018.3.9f1 using older versions of LWRP. This issue appears to have been resolved in LWRP 4.8.0. I would suggest updating to the latest LWRP release in the package manager (4.10.0 at the time of this post). If you still experience this issue after upgrading, consider filing a bug and attaching a repro project so we can investigate your issue directly (and leave a comment here so we can track it down).
     
    JasonCostanza likes this.
  11. Red_Dragon69

    Red_Dragon69

    Joined:
    Sep 7, 2015
    Posts:
    58
    I would say this is not fixed yet. I was able to reproduce the same behaviour with Windows MR UWP, Unity 2018.3.12f1 and LWRP 4.10.0
     
  12. Benjams

    Benjams

    Unity Technologies

    Joined:
    Oct 27, 2017
    Posts:
    13
    We were not able to reproduce this issue using 2018.3.12f1 with UWP and LWRP 4.10.0. I suggest filing a bug and attaching a repro project so we can investigate your issue directly. If you do file a bug, reply here so we can track it down.
     
  13. Red_Dragon69

    Red_Dragon69

    Joined:
    Sep 7, 2015
    Posts:
    58
    Hy @Benjams
    I filed a bug report today. The title is: "VR - WindowsMR HMD view is flipped upside down, when LWRP is enabled with MediumQuality or above"

    If you have any questions feel free to ask anytime :)
     
  14. Benjams

    Benjams

    Unity Technologies

    Joined:
    Oct 27, 2017
    Posts:
    13
    We have a fix for this issue that landed in 2018.4, so you should be able to access it whenever 2018.4 is available (very soon). This fix will also be available in the next release of 2019.1 (probably 2019.1.2f1 or later). Let us know if your issue is still not resolved after you've had an opportunity to test your project in one of these Unity releases.
     
    Red_Dragon69 likes this.
  15. Red_Dragon69

    Red_Dragon69

    Joined:
    Sep 7, 2015
    Posts:
    58
    Hy @Benjams,
    I was testing these days and just wnted to give you feedback about this.

    Still not working in 2018.4 -> I'm pretty sure this is an issue from the LWRP package 4.10.0
    BUT it's working as expected in Unity 2019.1.4, due to a newer Version of the LWRP package. :)

    Best regards.
     
  16. PanayotCankov

    PanayotCankov

    Joined:
    May 28, 2018
    Posts:
    10
    Package Manager update fixed this for me.
    This happened to me, the world was vertically flipped on WMR headset after starting a new project with Unity 2018.3.14f1. The LWRP was I think 4.1.0. After update from Package Manager to 4.10.0 the issue was resolved.
     
  17. Red_Dragon69

    Red_Dragon69

    Joined:
    Sep 7, 2015
    Posts:
    58
    What Quality Settings do you have in your project? When having LowQuality (in Project Settings->Graphics->Scriptable Render Pipeline Settings select Assets/Settings/LWRP-LowQuality) everything works fine, but all other quality settings result again in the flipped view.