Search Unity

Windows App Certification Kit Failure

Discussion in 'Windows' started by Aloisius64, Sep 25, 2019.

  1. Aloisius64

    Aloisius64

    Joined:
    May 31, 2019
    Posts:
    3
    Hi to everyone,

    recently I'm trying to build a package for the submission to the Windows store but i got the following error:

    L'API getenv in api-ms-win-crt-environment-l1-1-0.dll non è supportata da questo tipo di applicazione. UnityPlayer.dll utilizza questa API.

    It says that the api getenv is not supported. But it is any API used by UnityPlayer.dll.
    How can I do to correctly build the package for the Windows Store?

    I'm building the package in Master mode.
     
  2. Tautvydas-Zilys

    Tautvydas-Zilys

    Unity Technologies

    Joined:
    Jul 25, 2013
    Posts:
    6,540
    Hi,

    which Unity version are you on? Which Windows SDK are you using to run Windows App Certification Kit locally?
     
  3. Aloisius64

    Aloisius64

    Joined:
    May 31, 2019
    Posts:
    3
    Unity: Version 2019.1.10f1 Personal
    Windows SDK: 10.0.16299.0
     
  4. Tautvydas-Zilys

    Tautvydas-Zilys

    Unity Technologies

    Joined:
    Jul 25, 2013
    Posts:
    6,540
    So the issue here is that your Windows App Certification Kit is too old. The API in question (getenv) has been whitelisted for UWP apps in March, 2018 and looks like Unity started using it as a result. Windows SDK 16299 came out in 2017.

    Note that Microsoft always uses newest Windows App Certification Kit when you're submitting your store to the app, so this failure will not show up there.
     
  5. Aloisius64

    Aloisius64

    Joined:
    May 31, 2019
    Posts:
    3
    I have updated Visual studio to version 2019 and installed the latest Windows SDK and it works.
    Thanks.