Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Why PM is not in sync with Asset Store

Discussion in 'Package Manager' started by drndfx, Jan 17, 2019.

  1. drndfx

    drndfx

    Joined:
    Jul 3, 2013
    Posts:
    55
    I have a dillema. Packages such as Advertisement, Cinemachine, TextMesh Pro have totally different versions in Package Manager vs the Asset Store.

    Sometimes PM has newer versions and sometimes it is the opposite.

    This makes me not trust PM.

    When is Unity making PM in sync with Asset store? Should I keep using Asset Store?
     
  2. pedro_unity

    pedro_unity

    Unity Technologies

    Joined:
    Jan 16, 2017
    Posts:
    163
    Hi @drndfx,

    Not sure what you mean when you say:
    The packages you mentioned (i.e.: Advertisement, Cinemachine, TextMesh Pro) should be always newer in UPM. If that is not the experience you're seeing or having then you might have found an issue with the feature and I would appreciate you logging a defect, please take a look at: https://unity3d.com/unity/qa/bug-reporting.

    As for the second question:
    We're working on it. I wouldn't venture and tell you a release date/version. Yes, you should definitely keep using the Asset Store for Asset Packs, textures and third party tools.

    Cheers,
    Pedro
    Unity STE
     
  3. M_R

    M_R

    Joined:
    Apr 15, 2015
    Posts:
    518
  4. pedro_unity

    pedro_unity

    Unity Technologies

    Joined:
    Jan 16, 2017
    Posts:
    163
  5. pedro_unity

    pedro_unity

    Unity Technologies

    Joined:
    Jan 16, 2017
    Posts:
    163
    @M_R,

    Here's what I found out:

    That SDK release is not an exclusive release for the Asset Store. We're working on a package and will release that equivalency when it's ready.

    Cheers,
    Pedro
    Unity STE
     
    M_R likes this.
  6. drndfx

    drndfx

    Joined:
    Jul 3, 2013
    Posts:
    55
    Thank you for your answers.


    Here are some examples and how user like me thinks when using the product.


    I’m running Unity 2018.3.0f2, Package Manager 2.0.3


    1. PM has Advertisement 2.3.2 and when I click on View Documentation it takes me to Unity Ads page. That page specifically says “Unity recommends always using the latest Ads SDK” which takes users to Unity Monetization 3.0. So, I’m thinking I should go with 3.0 instead of using PM. Also, why they have inconsistent names like Advertisement, Unity Monetization etc. confuses users.
    2. PM “In App Purchasing 2.0.3”. I’m thinking is this the same thing as under Services menu and turning on In App Purchasing? Why does it have it’s own package when I can just turn it on using Services
    3. PM Cinemachine 2.2.8. Asset Store has the old version and it asks users to go back to PM to use it.
    4. PM TextMeshPro 1.3.0. Asset Store has version 1.2.2 and someone who does not know how to use PM will be downloading the old version from Asset Store.

    I know that things are still being developed, but making naming consistency and version numbering easier for users to understand would be a great help.


    Thanks.
     
  7. pedro_unity

    pedro_unity

    Unity Technologies

    Joined:
    Jan 16, 2017
    Posts:
    163
    That's good feedback @drndfx.

    I've started some discussions internally to provide more clarity to end users. Thank you for your help.

    Cheers,
    Pedro
    Unity STE
     
    M_R likes this.