Search Unity

Feedback Why is Unity getting slower with each new version?

Discussion in 'Editor & General Support' started by mrCharli3, Oct 21, 2022.

  1. mrCharli3


    Mar 22, 2017
    I just went from 2021.3.1 LTS to 2021.3.11 LTS and entering play mode now take 2 minutes instead of 50 seconds.

    I feel like the trend with each update I make is that Unity just gets slower. What is going on?
  2. Homicide


    Oct 11, 2012
    Unity has gotten slower over the years, but it is doing more, and it is adding more to empty projects with each year that passes it seems.

    Anyways, i too, was gettin very frustrated with recompile times etc etc... and i was reading a few threads around here and stumbled across a few things i decided to try, and for me, it worked big time. So, no guarantees, but you can try this and see if it helps some.

    Go into preferences, under Asset pipeline, disable directory monitoring, and autorefresh. Now, if you do this, you must remember, that unity will no longer automatically keep track of changes, so , things like adding assets , or most importantly, if you change and save a script, you will have to hit CTRL + R to refresh.

    Personally, it boosted my productivity ALOT, it seems to remove almost all of the hold ups.

    Anyways, good luck mate.
    Last edited: Oct 21, 2022
    mrCharli3 likes this.
  3. Tautvydas-Zilys


    Unity Technologies

    Jul 25, 2013
    Taking 50 seconds - 2 minutes entering playmode sounds insanely long. I suggest you try to profile and see what's taking the time. I would bet that something in your project is causing it and it shouldn't be too hard to improve it significantly.
    DevDunk likes this.
  4. spiney199


    Feb 11, 2021
    Also remove any packages you don't need. Default projects come with quite a few packages you either don't need immediately, and some you don't need at all (you don't need the code editor packages for all three major IDE's).

    Remove a bunch and you'll see a good improvement.