Search Unity

Bug Why I get "Unable to start Oculus XR Plugin" warning?

Discussion in 'VR' started by YanivAvr, Dec 22, 2021.

  1. YanivAvr

    YanivAvr

    Joined:
    Feb 13, 2021
    Posts:
    11
    Hi guys,
    Why this shows up?
    upload_2021-12-22_6-34-3.png
    Oculus XR Plugin and Oculus Integration are installed. my Quest 2 is connected with a link cable and an OVRCameraRig is setup in the scene. But when I press play in the editor, the game won't start on my headset.

    Thank you in advance.
     
  2. MurtleTheTurtle

    MurtleTheTurtle

    Joined:
    Dec 22, 2021
    Posts:
    2
    Have you made sure you have enabled link on the headset? You might also want to check the Oculus app to make sure you have enabled the 'Unknown Sources' setting enabled, otherwise it will not open.
     
  3. YanivAvr

    YanivAvr

    Joined:
    Feb 13, 2021
    Posts:
    11
    The two things that you mentioned are enabled. But sometimes I still get this warning..
     
  4. mohsenz

    mohsenz

    Joined:
    Aug 10, 2016
    Posts:
    29
    have you figured out the issue? It's not just a warning, it actually won't allow the project to run, I reinstall oculus XR, restart, create a new project, etc, still, the project won't show up on the headset while the Link is working correctly, any suggestion?
     
  5. KoMan_

    KoMan_

    Joined:
    Nov 24, 2021
    Posts:
    2
    I am currently having the same problem. I am using:
    XR PluginManagement 4.2.1
    Oculus XR Plugin 1.11.2
    Oculus Integration 37.0,

    When putting the OVRCameraRig into an empty scene and starting into playmode with quest 2 attached via cable and oculus link running the warning shows up and the quest stays in the link menu. Building the application and deploying to the quest 2 works just fine. Any help on this would be much appreciated.
     
  6. TzuriTeshuba

    TzuriTeshuba

    Joined:
    Aug 6, 2019
    Posts:
    185
    this has happened to me as id toggle the following setting for different builds, but make sure that in "edit/project settings/XR Plug-in management", you have "initialize xr on startup" checked, as well as "oculus". if youre trying to run on your PC via link, make sure the above mentioned checkboxes are marked in the PC tab, not just android.
     
  7. ETICS_Partners

    ETICS_Partners

    Joined:
    Jun 17, 2022
    Posts:
    1
    Same problem here.
     
  8. DiegoGonzalezOrtiz

    DiegoGonzalezOrtiz

    Joined:
    Feb 8, 2023
    Posts:
    2
    I had exactly the same problem guys and this was my solution: I had no idea that the oculus quest must be in quest link, no only connect the cable. Try go in Quest link mode and try run unity project.
     
  9. AmitTiwari4Unity

    AmitTiwari4Unity

    Joined:
    Aug 26, 2021
    Posts:
    7
    Did anyone find any solution for this bug?
    Because of this warning, I am not able to load the project on the quest link.
    Any help is appriciated.
     
  10. AdamBebkoFV

    AdamBebkoFV

    Joined:
    May 1, 2023
    Posts:
    9
    For me it was a setting in the Oculus app. (not MQDH). Settings/General then OpenXRRuntime then click on Set Oculus as Active
     
  11. fz19

    fz19

    Joined:
    Sep 10, 2023
    Posts:
    1
  12. mastermind07

    mastermind07

    Joined:
    Aug 22, 2023
    Posts:
    1
    Hey I am unable to set the OpenXR Runtime as active
    When I click on it nothing happens

    Please tell how to solve this?
     
  13. KoMan_

    KoMan_

    Joined:
    Nov 24, 2021
    Posts:
    2
    @mastermind07 I have the same issue.

    For me the solution is to set the Playmode OpenXR Runtime to Oculus in the XR PluginManagement Settings for OpenXR.
    upload_2023-9-19_16-11-41.png
    Feels a bit weird to set something for the OpenXR Plugin while actually using the Oculus Plugin but this way I can use the playmode in editor and run it on the quest 2 via link cable.
     
    Akakiakaki likes this.
  14. Akakiakaki

    Akakiakaki

    Joined:
    Feb 1, 2023
    Posts:
    8
    Thank you!!!!
    Worked for me!