Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Bug Why Alembic Animation is not rendering?

Discussion in 'Animation' started by scarscarin, Nov 16, 2020.

  1. scarscarin

    scarscarin

    Joined:
    Apr 5, 2019
    Posts:
    23
    Hi everybody :)

    I'm trying to create a 6dof VR environment that contains some Volumetric recordings I have done with Brekel Pointcloud v3 and a Kinect v2

    I am using Unity3D and its built-in Alembic package. Although it works ok in the Unity editor, once I build the app and run it, it won't show the Alembic files.

    I have tried different platforms such as Windows, Oculus Quest 2, and Google Chrome with the embedded WebGL, but in all these solutions I find the same issue. Other objects render just fine, while Alembics don't. I also tried using the Universal and HD Render Pipelines from Unity, with different materials and shaders, but nothing seems to work.

    Any clue?



    Leo
     
  2. arikoftikian2000

    arikoftikian2000

    Joined:
    Dec 5, 2020
    Posts:
    1
    Did you find a solution to this ?
     
  3. EssencyStudios

    EssencyStudios

    Joined:
    May 18, 2018
    Posts:
    11
    Having alembic objects disappear on me in the scene view, so far just saving my changes then reloading the scene to get them to appear again (disabling and reenabling those specific objects wont do anything)! Very odd hahaha.
     
  4. AVataRR616

    AVataRR616

    Joined:
    Feb 27, 2013
    Posts:
    21
    I have the same problem. Alembic animations work fine in the editor, but not in the WebGL build. I haven't tried other deployments yet
     
  5. Bussuf

    Bussuf

    Joined:
    Jan 24, 2022
    Posts:
    2
    I'm also having this problem, alembic objects work fine in editor and PC builds but not on WebGL builds.
     
  6. snorulf

    snorulf

    Joined:
    Oct 13, 2018
    Posts:
    5
    Made this tool to counter the same problem. Converts alembics into seperate mesh assets with a few helper scripts to animate them the same way you would an alembic file. https://github.com/snorulf/FlipBookMeshBaker
    Tried it on a Quest2 which is Android and it worked fine.