Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

white background after update

Discussion in 'Vuforia' started by glutvort, Aug 19, 2019.

  1. glutvort

    glutvort

    Joined:
    Apr 13, 2019
    Posts:
    31
    i Update unity to 2018.4.6f1, and vuforia to 8.3.8 in my project. When i start game in editor(this problem in build too) i see white background. I dont recieve real world image.How to fix it?!
     
  2. tomicz

    tomicz

    Joined:
    Mar 16, 2015
    Posts:
    126
    I have the black screen on Android. iOS is fine.
     
  3. Sika_MC

    Sika_MC

    Vuforia

    Joined:
    Jul 17, 2019
    Posts:
    42
    Hi @glutvort
    Do you see any errors in the console?
    From which SDK and Unity version did you migrate to 2018.4.6f1?


    I just saw your post with Vuforia ilcpp big problem and have the details. Let me investigate and I will come back.

    Thank you.
    Vuforia Engine Support
     
    Last edited: Aug 20, 2019
  4. glutvort

    glutvort

    Joined:
    Apr 13, 2019
    Posts:
    31
    I dont know how, but i fixed white screen))
    I have one more problem...
    my project was in unity 2018.2.20f and vuforia 7.5.26 and i dont have problems with tracking and my ar content dont lagging
    after update to unity 2018.4.6f1 and vuforia 8.3.8 i have lags in tracking and ar content super shaking

     
    Last edited: Aug 21, 2019
  5. tomicz

    tomicz

    Joined:
    Mar 16, 2015
    Posts:
    126
    My issue is with LWRP, it doesn't work with Vuforia on Andorid on the lastest Unity and Vuforia.
     
    mende likes this.
  6. Sika_MC

    Sika_MC

    Vuforia

    Joined:
    Jul 17, 2019
    Posts:
    42
    Last edited: Aug 22, 2019
  7. Sika_MC

    Sika_MC

    Vuforia

    Joined:
    Jul 17, 2019
    Posts:
    42
    Hi @tomicz

    Do you get the black background when using LWRP on Android? Could you please provide more details?

    Thank you.
    Vuforia Engine Support
     
    mende likes this.
  8. tomicz

    tomicz

    Joined:
    Mar 16, 2015
    Posts:
    126
    Yes, I do. I tested it on girlfriend's phone Xioami A2 Lite, the background is black. iOS (iPhone X) works perfectly. Camera still recognizes images/objects, it's just the background is black.
     
    mende likes this.
  9. mende

    mende

    Joined:
    Jun 11, 2013
    Posts:
    29
    Hi same problem here, like @tomicz described it. I tried a build without LWRP on Android and the camera is working. With LWRP package installed, there is a black background on the cam.
    I also tried and added this "LWRP Additional Camera Data (Script)" by clicking on render pipeline settings in the inspector of the camera. Unfortunately there was also no success, there is still a black bg.

    Unity version is 2019.2.2f1 Vuforia version : 8.3.8
     
    Last edited: Sep 3, 2019