Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We've updated our Terms of Service. Please read our blog post from Unity CTO and Co-Founder Joachim Ante here
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Audio Which engine version should I use to export my Sound Effects Packs to sell in the Asset Store ?

Discussion in 'Audio & Video' started by OGsoundFX, Jan 7, 2019.

  1. OGsoundFX

    OGsoundFX

    Joined:
    Mar 22, 2018
    Posts:
    6
    Hello,
    I am not sure where to ask this question, but I thought users were probably the best people to answer my question.
    I recently added these 2 sound effect packs in the asset store (Guns & Explosions and Underground Atmospheres), that I have exported using one of the latest version of the unity engine (2018.2.15), and i was wondering if I should re-export them in an older version (like the 5.6), so that game developers using these older versions can acquire them too ? Does that make sense ?

    Thanks in advance for your replies !
    Best,
    Olivier Girardot
     
  2. r618

    r618

    Joined:
    Jan 19, 2009
    Posts:
    700
    you have just wav (presumably 1-, or 2-channels) audio files in your packages - those are version independent, they are _imported_ into the editor regardless of its version since these are supported probably since Unity 1.0 (alpha)
    I have no idea what you mean by
    though
    Do you mean _submitted_ to asset store ? - That will be the version displayed as 'Supported/submitted' on the asset store page
    So you should submit with lowest version possible - i.e. from lowest Unity version which asset store tools still support
     
  3. OGsoundFX

    OGsoundFX

    Joined:
    Mar 22, 2018
    Posts:
    6
    To submit an audio pack to the asset store, I need to export it through the Unity Engine so the sounds are directly usable inside your project.
    But someone on reddit told me this: "I think you might lose purchasers because it might turn people off seeing a fairly recent Unity version there. You might want to consider uploading from say the last 5.6 release available."
     
  4. r618

    r618

    Joined:
    Jan 19, 2009
    Posts:
    700
    Yes mate, you indeed have - that's what 'Asset Store Tools' are for and that's what I was asking about and their minimal Unity version support I was implying :
    Good luck !
     
  5. OGsoundFX

    OGsoundFX

    Joined:
    Mar 22, 2018
    Posts:
    6
    OK, thank you very much for your help !
     
  6. OGsoundFX

    OGsoundFX

    Joined:
    Mar 22, 2018
    Posts:
    6
    oh, by the way, what version should I go for. Is 5.6 enough, or should I choose an even older version ?
    Thanks !
     
  7. r618

    r618

    Joined:
    Jan 19, 2009
    Posts:
    700
    You might / should choose the lowest possible, since they are just audio files :) AST should be able to submit from as low as 5.0.0
    Good luck !
     
  8. OGsoundFX

    OGsoundFX

    Joined:
    Mar 22, 2018
    Posts:
    6
    Perfect ! Thank you so much !