Search Unity

Where did the Materials buttons go?

Discussion in 'Editor & General Support' started by PM1503, Oct 26, 2018.

  1. PM1503

    PM1503

    Joined:
    Oct 19, 2018
    Posts:
    2
    When importing models from Blender to Unity, I usually change the import settings for materials.I used to chose "Use External Materials (Legacy)" instead of "Use External Materials" and everything was fine.
    see also https://docs.unity3d.com/Manual/FBXImporter-Materials.html#Legacy

    Now this option seems to be gone (Unity 2018.2.13). Under import settings/Materials I can only chose "Import material" yes or no but there are no sub-options whatsoever. This means that my models are not imported properly (i.e. missing faces).

    Does anyone know how can I change this? Where did this option go?
     
    Last edited: Oct 26, 2018
    altair2020 likes this.
  2. dgoyette

    dgoyette

    Joined:
    Jul 1, 2016
    Posts:
    1,756
    altair2020 likes this.
  3. altair2020

    altair2020

    Joined:
    Mar 6, 2011
    Posts:
    28
    yep, i got the same problem in 2018.2.13f1 the button(s) is missing:

    upload_2018-10-27_21-13-18.png

    Looks like 2018.2.14 Fixed the issue.
     
    Last edited: Oct 28, 2018
  4. PM1503

    PM1503

    Joined:
    Oct 19, 2018
    Posts:
    2
    Just downloaded it and it works! Thanks!
     
  5. dgoyette

    dgoyette

    Joined:
    Jul 1, 2016
    Posts:
    1,756
    Altair2020, just making sure you noticed that this is fixed in 2018.2.14, which you can download now.
     
    altair2020 likes this.
  6. altair2020

    altair2020

    Joined:
    Mar 6, 2011
    Posts:
    28
    Yes is did, thanks 2018.2.14 fixed the issue.