Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Question Where are the docs for the Advertisement with mediation?

Discussion in 'Unity Ads & User Acquisition' started by Cuicui_Studios, Feb 24, 2023.

  1. Cuicui_Studios

    Cuicui_Studios

    Joined:
    May 3, 2014
    Posts:
    72
    Hi there guys,
    We started implementing Ads for our mobile game following the docs. We got to a point in which we got the system 'working' in editor. So we dropped a build to mobile device and... crash upon launching rewarded video ad (which is the only ad unit we are currenntly using).
    Rolled sleeves up and dug into everything (logcat and everything).
    So, docs tell you to install Advertisement package, ¿right? That's how we made it work in editor and stuff. But upon opening the services dashboard panel in unity editor and turning Ads on, it tells you that current Advertisement package is 4.3.0 and you should install 4.4.1, all right. We do that and... Advertisement package gets uninstalled and instead we have Advertisement with Mediation package 1.0.5 installed? Which is different than the docs? Also, when we do that all our interfaces and stuff turn into errors everywhere. So we go to the docs directly from the Ads section (which BTW says 'current version N/A') by clicking on the link of the services panel and it directs you to the tocs that tell you to install Advertisement package???? It also says 'last version 4.4.1', which should be the version I installed? But it's not?
    So. Where are the docs for implementing the Advertisement with Mediation package 1.0.5?
    Thanks in advance.
     
  2. aylin_unity3d

    aylin_unity3d

    Unity Technologies

    Joined:
    Apr 6, 2015
    Posts:
    48
    Hi, Sorry for all the confusion. If you would like to use UnityAds only, you can stick to Advertisement package is 4.3.0 or 4.4.1.
    If you wish to use mediation, then you should use the level play.
    For the levelplay install guide, please refer to this
    For further levelplay integration, please refer to the levelplay official doc here