Search Unity

Question When creating a project on 2022.3.16f1, the Rider libraries are not installed

Discussion in 'Code Editors & IDEs' started by Whiskas009, Feb 21, 2024.

  1. Whiskas009

    Whiskas009

    Joined:
    Aug 21, 2022
    Posts:
    27
    Hello! I want to create a project using version 2022.3.16f1, but after creating it, the Rider libraries are not installed, and the script editor cannot be selected in “External Tools”.

    Everything installs well on version 2022.3.13f1. But if you transfer the project later to version 2022.3.16f1, then errors appear again
     

    Attached Files:

  2. Spy-Master

    Spy-Master

    Joined:
    Aug 4, 2022
    Posts:
    564
    On an empty 2022.3.16f1 project, adding com.unity.ide.rider 3.0.27 works fine on my end.

    If Library\PackageCache\com.unity.ide.rider@3.0.27\Rider\Editor\JetBrains.Rider.PathLocator.dll isn't present, maybe there's some issue with antivirus or other software such that your 2022.3.16f1 installation's creation of dll files is interfered with. It's just odd that the issue is with a specific version, and that updating an existing project fails too. 2022.3.20f1 is the latest 20222.3 release, you could try updating to that first.
     
    Last edited: Feb 21, 2024
  3. Whiskas009

    Whiskas009

    Joined:
    Aug 21, 2022
    Posts:
    27
    I installed version 2022.3.20f1, the error also appears
    Installation via com.unity.ide.rider@3.0.27 does not help
     
  4. Spy-Master

    Spy-Master

    Joined:
    Aug 4, 2022
    Posts:
    564
    Perhaps check/post your Editor.log file for anything anomalous besides those errors.
     
  5. van800

    van800

    JetBrains Employee

    Joined:
    May 19, 2016
    Posts:
    73
    Last edited: Feb 21, 2024
  6. Whiskas009

    Whiskas009

    Joined:
    Aug 21, 2022
    Posts:
    27
  7. Whiskas009

    Whiskas009

    Joined:
    Aug 21, 2022
    Posts:
    27
    Clearing the global UPM cache and then re-creating the project helped