Search Unity

  1. Unity 2020.1 has been released.
    Dismiss Notice
  2. We are looking for feedback on the experimental Unity Safe Mode which is aiming to help you resolve compilation errors faster during project startup.
    Dismiss Notice
  3. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Whats up with the standard asset Water (Basic)?

Discussion in 'Editor & General Support' started by AaronC, Aug 27, 2014.

  1. AaronC

    AaronC

    Joined:
    Mar 6, 2006
    Posts:
    3,546
    Hi, I know not many of us would use this, but I'm looking at tutoring a group of students, who won't all be making a 3rd party purchase of a water asset.

    However Unitys default asset "Water (Basic)" looks totally poked. I've used this many times before but the Unity 4.5 asset seems to be really messed up. Can someone from Unity tech please take a look. I'll update this with a bug number once I get a confirmation email. Thanks
     
  2. AaronC

    AaronC

    Joined:
    Mar 6, 2006
    Posts:
    3,546
    Filed as bug report 629077
     
  3. AaronC

    AaronC

    Joined:
    Mar 6, 2006
    Posts:
    3,546
    Can someone from Unitytech check this please?
     
  4. kablammyman

    kablammyman

    Joined:
    Nov 22, 2010
    Posts:
    507
    are you also getting an error on the water shader, because I am with the car tutorial
     
  5. AaronC

    AaronC

    Joined:
    Mar 6, 2006
    Posts:
    3,546
    Yes, and I even made a fresh project with nothing in it except the basic water asset. Looks awful.
    The Unity guys should really be QA'ing this..
     
  6. mgear

    mgear

    Joined:
    Aug 3, 2010
    Posts:
    6,142
  7. kablammyman

    kablammyman

    Joined:
    Nov 22, 2010
    Posts:
    507
    my bug is different. The water is all pink (as in, broken, not pink colored water)

    I get these shader errors:
    Code (csharp):
    1.  
    2. Shader error in 'FX/Water': 'vert': function return value missing semantics at line 82
    3. Shader error in 'FX/Water': 'frag': input parameter 'i' missing semantics at line 125
    4. Shader warning in 'FX/Water': Upgrade NOTE: SubShader commented out because of manual shader assembly at line 182
    5.  
     
  8. AaronC

    AaronC

    Joined:
    Mar 6, 2006
    Posts:
    3,546
    Thanks mgear, that was the issue.

    @kablammyman this is my working default shader
     

    Attached Files:

    kablammyman likes this.
  9. kablammyman

    kablammyman

    Joined:
    Nov 22, 2010
    Posts:
    507
    thanks for this, it worked perfectly
     
unityunity