Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

What's the best way to achieve antialiasing in VR (Oculus Rift S and Quest)

Discussion in 'VR' started by bmoodyP3, Jul 26, 2019.

  1. bmoodyP3

    bmoodyP3

    Joined:
    Jul 23, 2019
    Posts:
    12
    Hi All,

    I'm currently building a VR application for the Quest and Rift S.

    However, I am having a hard time getting rid of jagged edges in my scene, especially with UI elements.

    I have already tried:

    1. Increasing the antialiasing settings in Project Settings / Quality / Rendering / Antialiasing. Antialiasing is currently set to 8X multi-sampling.
    2. Adding an antialiasing effect via Unity's postprocessing stack.
    3. In the UI's canvas scaler, setting the Dynamic Pixels Per Unit to a high number.

    Do you have any other advice for achieving antialiasing in VR?

    My understanding is that the Light Weight Render Pipeline can be good for rendering mobile VR games, such as for the Quest. Would switching to the LWRP at this point help solve this antialiasing issue? (I don't think they are connected but I figure it is worth asking.)
     
  2. Skeketor23

    Skeketor23

    Joined:
    Apr 6, 2019
    Posts:
    49
    I'm also fighting with aliasing on the Quest. And I'm using LWRP. Don't think that it will help ;)
     
  3. chakravarthye

    chakravarthye

    Joined:
    Mar 1, 2019
    Posts:
    1
    I am developing VR for oculus rift S. . . . . The biggest problem is the anti-aliasing.

    I have tried these two options:
    1. CTAA from assetstore. This one works but produces an overall blurry output.
    2. Madgoat SSAA from assetstore: This one improves the output slightly but it brings down the performance considerably.

    I am considering testing ont VR in unreal also to find out if is any better.
     
  4. Elin42

    Elin42

    Joined:
    Oct 21, 2014
    Posts:
    22
    @Skeketor23
    Are you using the Oculus Integration from the asset store?
    When I try to use the oculus prefab I only got a black screen on the quest. But when using unity's XR rig everything is fine. The problem is, that I can't code and need the locomotion system from the oculus controller
     
  5. hawken

    hawken

    Joined:
    Aug 22, 2013
    Posts:
    535
    Oculus recommend using 4x MSAA
     
  6. AccentDave

    AccentDave

    Joined:
    Nov 16, 2015
    Posts:
    43
    Would you mind leading us through that? I've found several posts which say this, but all seem to be somewhat incomplete or out of date, and in any case assumes the developer is very savvy about all settings involved.
     
  7. hawken

    hawken

    Joined:
    Aug 22, 2013
    Posts:
    535
    project settings > quality > Anti Aliasing
     
  8. darkesco

    darkesco

    Joined:
    Mar 19, 2015
    Posts:
    39
    So does anti aliasing work on LWRP? I really like shader graph, but setting AA to off or 8X in the pipeline asset appears to have no change on Quest.
     
  9. nomand

    nomand

    Joined:
    Dec 23, 2008
    Posts:
    43
    Tested both on URP and LWRP in 2019.2.12 and 2019.3, set AA to 4x in the Scriptable Pipeline file (according to Oculus developer portal). On the main center camera, turn MSAA settings to "use pipeline", go to OVRManager and uncheck the Antialiasing settings there to make sure that pipeline doesn't get overriden.
    make sure that your main camera is actually tagges as Main Camera.
     
    SladeCU likes this.
  10. SladeCU

    SladeCU

    Joined:
    Mar 25, 2019
    Posts:
    4
    ^ This works- going into the center camera and make sure MSAA says "Use Graphics Settings." After that, make sure you do what hawken mentioned above and go into Quality and change MSAA to 4x. If you don't, there should be a dialogue in the camera under the MSAA telling you that you need to change it in the quality settings. I set my quality to Medium and with the MSAA there were no "dancing lines" on hard edges anymore.

    Context: I'm developing on Quest using Unity 2019.2.12f1 with 3D pipeline (not using LWRP).
     
  11. saifshk17

    saifshk17

    Joined:
    Dec 4, 2016
    Posts:
    271
    I cant find the option to "uncheck the Antialiasing settings". I am using Unity 2019.2.13f1
     
  12. SladeCU

    SladeCU

    Joined:
    Mar 25, 2019
    Posts:
    4
    These are where I found everything. Mine didn't say "Antialiasing settings" exactly, but these are the things I checked and unchecked in the OVRManager script and the center Camera OVRManager.JPG CameraSettings.jpg CameraSettings.jpg
     
  13. saifshk17

    saifshk17

    Joined:
    Dec 4, 2016
    Posts:
    271
    I have followed the same settings but I still have the problem of flickering meshes. I am using LWRP.
     
  14. netpost

    netpost

    Joined:
    May 6, 2018
    Posts:
    203
    I also have this problem but this is more obvious when my camera is moving , like slowly following a path. I can't get rid of this problem. My best option is to keep my camera steady which is kind of limiting and boring.
     
  15. unity_llrz2EE34jZn-w

    unity_llrz2EE34jZn-w

    Joined:
    Dec 6, 2018
    Posts:
    1
    Hello,

    I also tried the solution with pipeline, but the problem is when i built the game, there is no .exe file. What am i missing here?

    Thanks
     
  16. JoelLB

    JoelLB

    Joined:
    Oct 9, 2019
    Posts:
    18
    Build with as APK
     
unityunity