Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We've updated our Terms of Service. Please read our blog post from Unity CTO and Co-Founder Joachim Ante here
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

weird zoom behaviour in cinemachine framing transposer

Discussion in 'Cinemachine' started by chlagou, Dec 19, 2017.

  1. chlagou

    chlagou

    Joined:
    Jan 15, 2014
    Posts:
    9
    Hey Guys, I want to know if this is done by design or it's a bug?



    you will find my setup in the View attachment 259280 attached image


     
  2. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    1,911
    Yes the zoom behaviour is expected. Because the target is moving closer/farther away within the dead zone, the zoom is adjusting to keep the framing size constant. In the current version, the framing functionality ignores the dead zone.
     
  3. chlagou

    chlagou

    Joined:
    Jan 15, 2014
    Posts:
    9
    thank you ! for your quick response, but is there a way to enable/disable the zoom, I know it sounds stupid but there is no other way to do top-down camera in cinemachine
     
  4. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    1,911
    I can't open your attachments from you original post, so I don't know your setup. Is your Follow Target a TargetGroup? If so, that's why you're getting the zoom. Make it an ordinary transform instead (i.e. NOT a TargetGroup) and the zooming should stop because the vcam has no way to know the target size.
     
  5. chlagou

    chlagou

    Joined:
    Jan 15, 2014
    Posts:
    9
    cinemachine setup.JPG
     
  6. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    1,911
    Thanks. So it's not the Framing functionality. I think the problem is that there's no way to confine the vcam with the Framing Transposer to a plane parallel to the XZ, unless you get rid of the dead zone. Can you live without the dead zone for now?
     
    chlagou likes this.
  7. chlagou

    chlagou

    Joined:
    Jan 15, 2014
    Posts:
    9
    yes, that's what I did. thank you so much :D
     
  8. Tony707

    Tony707

    Joined:
    Jun 15, 2015
    Posts:
    35
    Any updates on this ?

    Is there any way to avoid the zooming behavior when inside the dead zone ?

    Thanks
     
  9. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    1,911
  10. Tony707

    Tony707

    Joined:
    Jun 15, 2015
    Posts:
    35
    Thanks for the suggestion,

    Actually since we change the camera distance during runtime I don't see this as a viable solution, I'll try to find another way.
     
  11. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    1,911
    You could probably work out the mathematical relationship between camera distance and z depth - my intuition is that it just scales linearly. So get it working at one distance, and just scale the dead zone depth along with the camera distance. Betcha that would work.
     
    Tony707 likes this.