Search Unity

WebGL will only publish with FIPS disabled

Discussion in 'WebGL' started by unklebooey1, Apr 25, 2017.

  1. unklebooey1

    unklebooey1

    Joined:
    Jul 30, 2013
    Posts:
    4
    When I was trying to publish for WebGL with 5.6.0 on Windows 7, IL2CPP kept crashing even with a blank scene:
    https://forum.unity3d.com/threads/w...er-building-native-binary-with-il2cpp.466196/

    So with further research I noticed the line in my logs: "This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms"

    Going to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\FipsAlgorithmPolicy and setting enabled to "0" instead of "1" allows me to successfully build for WebGL, which effectively disables FIPS.

    I noticed this on Microsoft's website:

    "Microsoft .NET Framework applications such as Microsoft ASP.NET only allow for using algorithm implementations that are certified by NIST to be FIPS 140 compliant. Specifically, the only cryptographic algorithm classes that can be instantiated are those that implement FIPS-compliant algorithms. The names of these classes end in "CryptoServiceProvider" or "Cng." Any attempt to create an instance of other cryptographic algorithm classes, such as classes with names ending in "Managed," cause an InvalidOperationException exception to occur. Additionally, any attempt to create an instance of a cryptographic algorithm that is not FIPS compliant, such as MD5, also causes an InvalidOperationException exception"

    https://support.microsoft.com/en-us...n-windows-xp-and-in-later-versions-of-windows

    Not sure what to do about this, I feel like I shouldn't be disabling this feature?


    Thanks,
    Perry
     
    Last edited: Apr 25, 2017
    Jude77 likes this.
  2. Stesproject

    Stesproject

    Joined:
    Apr 8, 2017
    Posts:
    12
    Hi unklebooey,
    I get the same problem when I try to build for WebGL with Unity 5.6 and I don't understand how to solve it.
    How can I going to HKEY_LOCAL_MACHINE/... ?

    Thanks for the help.
     
    kkaldas likes this.
  3. Vasilkb

    Vasilkb

    Joined:
    Jun 4, 2015
    Posts:
    15
    i have the same problem
     
  4. Z3uS

    Z3uS

    Joined:
    Feb 25, 2015
    Posts:
    2
    Windows-R --> regedit
     
  5. SoshJam

    SoshJam

    Joined:
    Dec 23, 2016
    Posts:
    4
    Mac solution?
     
  6. Annundur

    Annundur

    Joined:
    Dec 18, 2018
    Posts:
    12
    I'm getting the same problem, two years later. However I checked my FipsAlgorithmPolicy setting and it's enabled = 0 already. Any other way to solve this?

    Thank you very much
     
  7. bugfinders

    bugfinders

    Joined:
    Jul 5, 2018
    Posts:
    131
    Id like to add ditto with 2018.3f2

    it seems to cause also weird behavior with native builds too, hundreds (litterally) of processes appear and hang around and it takes forever to build too
     
    Last edited: Jan 28, 2019
  8. Jerdz

    Jerdz

    Joined:
    Sep 19, 2018
    Posts:
    1
    In 2019, the bug is still here, not only Unity crashes but also my ENTIRE COMPUTER SHUTS DOWN, I've tried everything, my FipsAlgorithm was already disabled, I am trying on a blank project, the computer still shut down at the "Build native binary stage with IL2CPP" stage.
    Why they haven't fix that issue after so many years ???
     
    mablack and Natka_B like this.
unityunity