Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Question webgl urp and leaking light

Discussion in 'Web' started by bugfinders, Nov 4, 2023.

  1. bugfinders

    bugfinders

    Joined:
    Jul 5, 2018
    Posts:
    1,438
    So, i dread to think how many hours over the course of what ive done, ive wasted on light leakage..so, to give you an idea, heres what the corridor in questions light looks like in the ide - and what my expectations where, given there are zero lights in the corridor. (there can be and thats a dynamic light)

    upload_2023-11-4_17-5-39.png

    yes, it is supposed to be that dark

    now, running in the ide, there is no light leakage, the light map looks reasonable, all the walls, ceiling et al is marked double sided (even though its actually thick enough IMHO), ive stitched seams, ive tweaked a lot.

    here in the ide during play
    upload_2023-11-4_17-8-26.png

    perfect

    and yet built as webgl
    upload_2023-11-4_17-10-18.png

    if i move around, this is about as dark as it goes but some flicker on and off


    as the wall is in 3 segments, that middle bit of wall? - gets this odd shaped stupid bit right in the middle of the wall! (there are candles on a table the other side)

    upload_2023-11-4_17-14-22.png

    i had better luck with built in this is urp, i did have light probes but somehow all the light probe stuff proper broke in 2023.3 which im trying it out on, and tbh before you ask, i seem to chase this constantly irrelevant of which version it is..

    so this is urp with forward rendering

    can someone explain to me how to fix it, so i really dont have to do this again? cos just usually when i think i fix it, a few builds later its not.

    PS having measured it, the walls are 50cm thick (yes really) and here are the settings on all walls, ceiling, floor, arches, doorways and yes all static with static llights
    upload_2023-11-4_17-28-34.png
     
    Last edited: Nov 4, 2023
  2. KamilCSPS

    KamilCSPS

    Joined:
    May 21, 2020
    Posts:
    431
    Have you tried building a standalone build and see if it's there too?

    If yes - might want to post this in the URP forums.
     
  3. bugfinders

    bugfinders

    Joined:
    Jul 5, 2018
    Posts:
    1,438

    i dont need any other form of build than webgl, so to an extent, its irrelevant if it happens in any other. It looks fine in the IDE, despite confirming all settings should be the same. So, no, building for windows it doesnt do the same..
     
  4. KamilCSPS

    KamilCSPS

    Joined:
    May 21, 2020
    Posts:
    431
    It's not irrelevant if the issue is URP and not WebGL. Which means you are barking at the wrong forums for help.

    What renders in IDE is generally meaningless - it's always the build that counts.

    And finally, if you really want this to be resolved, you should always file a bug with repro project.
     
  5. bugfinders

    bugfinders

    Joined:
    Jul 5, 2018
    Posts:
    1,438
    tbh like many others the reporting bugs is like whispering at a rock concert, I do report bugs, but i came here for advice because clearly some people make it work - so advice was needed, and as i purely work in webgl and the problem appears in the webgl client, this does seem the right place.

    yes and l imagine just like all the other times, they dont just open a project and do the instructions, the guy changed so much (as he showed me a picture) it wasnt surprising he couldnt recreate it.. I dont fancy another 2 month battle to say just open it and do it as it is.. they ask for a repro, you provide something that does exactly that and.. nope.
     
  6. KamilCSPS

    KamilCSPS

    Joined:
    May 21, 2020
    Posts:
    431
    That's not my experience but YMMV.

    I get the frustration but in the end, if you show you're willing to help them and with the right cooperative attitude, it moves things along faster.

    At the very least triaging if it's a URP vs WebGL bug will get you faster help. And by posting this in URP forums you get access to the people / devs who actually know about rendering vs "web platform". And this is clearly a rendering issue. So there's that.
     
  7. bugfinders

    bugfinders

    Joined:
    Jul 5, 2018
    Posts:
    1,438
    As mentioned earlier, it does not happen in a windows build.. so, it is a webgl issue area.