Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

WebGL for Unity 2019 1.4 shows black screen after default loading screen done in all browsers

Discussion in 'WebGL' started by indys, Oct 22, 2019.

  1. indys

    indys

    Joined:
    Jul 16, 2017
    Posts:
    10
    Hello,

    I've been trying for days to figure this out.

    I export my games using WebGL. Build succeeds. Tab in Chrome automatically opens. Everything looks fine, the default loading screen does its thing, then, nothing. Game area remains black.

    I've tried exporting my actual game, and when that didn't work, I made a basic test game.

    I made a basic test game with nothing but a canvas and a camera. Other than changing the transform values of canvas and camera, and changing canvas to World Space in order for the camera to render the scene properly, I didn't change anything. I didn't make or add any scripts or folders.



    In Build settings, I made sure to check off Dev Build and Autoconnect profiler:


    Here are the results from console (tried Googling the errors, couldn't make sense of the few results that came up):



    Here are the Player Settings screenshots:




    **NOTE: I tried changing API compatibility level to 4.0 but that didn't make a difference.**



    Result in Chrome (after default loading scene done):


    I have also exported this test project, you can download it here.

    I have tested this on Chrome, Firefox, and Edge. None of them will move beyond the loading screen.

    Running Windows 10 on a laptop with Core i7 & Nvidia.

    Unity version is 2019.1.4, educational version. I am forced to use this version because I am teaching Unity to students and the school's IT department will not let me install another version.

    In addition, our exported games must be WebGL because it's the only file type students can run due to permission restrictions on our school's computers.

    WebGL has never given us any issues before. Any help is appreciated. Thanks in advance.
     
  2. indys

    indys

    Joined:
    Jul 16, 2017
    Posts:
    10
    Forgot to mention I also cleared all of my browsers' caches and that didn't help either.
     
  3. savely00

    savely00

    Joined:
    Feb 27, 2014
    Posts:
    31
    You published build directory only. I downloaded and ran it and it shows a few errors in the console.
    Cannot help more without the actual project.