Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Our response to Improbable’s blog post (and why you can keep working on your SpatialOS game). Read more here
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

WaitForTargetFPS occurs when vsync is disabled.

Discussion in 'Android' started by MUGIK, Jan 11, 2019 at 5:07 PM.

  1. MUGIK

    MUGIK

    Joined:
    Jul 2, 2015
    Posts:
    114
    Today I faced problem with my android game. I had 27 FPS on device. With Profiler I was able to locate problem. It was WaitForTargetFPS. As always, I just disable vsync on every quality setting, because this works for me all the time. But now this didn't help, so I started to check my shaders, GC, multithreaded rendering... After several hours of ****, I decided to try to enable vsync. And this helped!

    I didn't find anything similar to my situation on the internet, that's why I writing this post.
    Unity 2018.3.0f2

    Also, now almost 50% of load consumed by Present.BlitToCurrentFB, and I can't find anything about that on forums.
    upload_2019-1-11_19-2-0.png
    But, I have 55 fps on device. My device screen support 55 fps max, so... I think that Device.Present represents vsync.

    UPD:
    Device.Present happens when Multithreaded Rendering disabled. If enabled, then Gfx.WaitForPresent appears.
     
    Last edited: Jan 11, 2019 at 5:18 PM