Search Unity

Vuforia currently does not support the IL2CPP scripting backend for UWP

Discussion in 'Vuforia' started by P4blo, Jan 10, 2019.

  1. P4blo

    P4blo

    Joined:
    Dec 12, 2012
    Posts:
    18
    Hello all,
    I'm getting the next error when trying to build a UWP build for HoloLens:

    Vuforia currently does not support the IL2CPP scripting backend for Windows Store Apps. Please select ".NET" as the scripting backend in the "Other Settings" section of the Player Settings

    The weird thing is that I have been building the project using the IL2CPP scripting backend without any problem for the last weeks but today suddenly this error appeared.

    Any idea why Vuforia does not allow me to build using IL2CPP scripting backend?
    I have try Unity 2017.4.17 and 2017.4.18;

    As I said with Unity 2017.4.17 I was building so many times without any problem.
    I can't find any similar problem in the forums.

    Cheers

    00Config.png 01Error.png
     
  2. meedabit

    meedabit

    Official Vuforia Employee Vuforia

    Joined:
    Dec 8, 2016
    Posts:
    174
    Hello,

    Which version of Vuforia are you using with 2017.4?

    Thanks,
    Vuforia Engine Support
     
  3. P4blo

    P4blo

    Joined:
    Dec 12, 2012
    Posts:
    18
    Hello,

    I'm using Vuforia 7.0.57, the default one shipped with Unity 2017.4.18

    Edit:
    I have uninstall all Unity versions on my laptop and install them again. Still with the same error.
    However my colleague can build the project with the same Unity version without any problem.
    So, the problem is only happening in my laptop.

    I don't know what else I need to uninstall and install again...
     
    Last edited: Jan 11, 2019