Search Unity

Vuforia AR Camera getting blurry

Discussion in 'Vuforia' started by ST_ProductVIz, Jan 8, 2019.

  1. ST_ProductVIz

    ST_ProductVIz

    Joined:
    Nov 29, 2017
    Posts:
    9
    Hey,

    I am developing an AR App with CloudReco and noticed a strange behavior. When my app starts it starts with the AR Scene and everything works as expected,

    See Screenshot1. Screenshot1.jpg

    When i am leaving the scene (loading a normal scene without AR components, in my case the mainMenu and destroying the current scene) and switching back to this AR scene (this scene is newly loaded no persistent things stored somewhere) i am receiving a blurry AR Cameraimage.

    See Screenshot2. Screenshot2.jpg

    But the camera itself works, because he finds the target. Only the visual preview seems wrong. And my transparent Menubars(top and bottom) disappeared aswell... but the icons/buttons are still here.

    And finally when i am pressing the button to switch to the MainMenu again (like i did the first time) the app freezes/crashes...

    I tested it on Galaxy S8 and Huawei MediaPad M3 both running Android 8.

    Windows 10 with current Updates

    Unity 2018.3.0f2

    Vuforia 7.5.26

    Android SDK including 26, 27 and 28 is installed

    I also attached the logfile.


    Thanks in advance for your help!
     

    Attached Files:

  2. ST_ProductVIz

    ST_ProductVIz

    Joined:
    Nov 29, 2017
    Posts:
    9
    [Update:] it is not solved...
    i disabled both things and still getting this error... any hints?

    @Vuforia-Strasza ?

    Thanks.

    ----------------------------------------------------------------------------------------------------
    Solved...

    After a couple of hours of investigation what i changed the last weeks, i found out that i implemented the ScanlineAnimation from the Vuforia Bookssample and added the "Reporter" Asset for debuginformation during devicetests to my project aswell. Looks like they are not working well together and causing this strange behavior...
     
    Last edited: Jan 10, 2019
    meedabit likes this.
  3. ST_ProductVIz

    ST_ProductVIz

    Joined:
    Nov 29, 2017
    Posts:
    9
    Maybe editing the last post was not the best idea... now it is a little bit confusing...

    But I am still having this issue...

    Anybody a guess? @meedabit @Vuforia-Strasza
     
  4. ST_ProductVIz

    ST_ProductVIz

    Joined:
    Nov 29, 2017
    Posts:
    9
    okay, what i found out so far is, that the target recognition works as expected, whereas the visual representation of the camera is wrong. looks like the camera image is zoomed in on a couple of pixels and is then interpolated for the fullscreen resolution of the devicescreen.
    And sometimes the error occurs every time and sometimes the error disappears for a couple of app starts...