Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Bug VSync Rendering issue with most existing games maxes out CPU when it should be idling

Discussion in 'Linux' started by Job, Aug 26, 2015.

Thread Status:
Not open for further replies.
  1. Job

    Job

    Joined:
    May 24, 2013
    Posts:
    2
    Not sure if this is still an issue with the newer versions of Unity3D, but probably worth mentioning just to be sure (and to encourage developers to create a simple bug-fix of existing games).

    My laptop is a Lenovo t440s with a Geforce GT 730M, running Ubuntu 15.04 and using the NVIDIA binary driver version 346.59. I've noticed that most of my Unity games max out a CPU core, even when idling. This has the very real consequence of heating up my laptop and draining my batteries quickly.

    Reported earlier here:

    http://forum.unity3d.com/threads/bu...-out-cpu-core-on-linux-for-many-games.349464/

    Thanks to a bit of help from the King Kadelfek on the TIGSource forums, some more details have been discovered. See: http://forums.tigsource.com/index.php?topic=43986.msg1171989#msg1171989

    Results from testing this on my machine:

    Based the tests so far, it seems that this is something that goes wrong because the default settings are somehow different than on Windows, where the same games don't have this issue for me (I dual boot). It should not be too complicated to fix once the exact cause is determined.

    Please fix it - think of the mobile users!
     
  2. Tak

    Tak

    Joined:
    Mar 8, 2010
    Posts:
    1,001
    This isn't related to Unity editor on Linux - please file a bug report through the proper channels.
     
Thread Status:
Not open for further replies.