Search Unity

  1. Get all the Unite Berlin 2018 news on the blog.
    Dismiss Notice
  2. Unity 2018.2 has arrived! Read about it here.
    Dismiss Notice
  3. Improve your Unity skills with a certified instructor in a private, interactive classroom. Learn more.
    Dismiss Notice
  4. ARCore is out of developer preview! Read about it here.
    Dismiss Notice
  5. Magic Leap’s Lumin SDK Technical Preview for Unity lets you get started creating content for Magic Leap One™. Find more information on our blog!
    Dismiss Notice
  6. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

VS for Mac doesn't format code as expected

Discussion in 'External Tools' started by novaVision, Feb 13, 2018.

  1. novaVision

    novaVision

    Joined:
    Nov 9, 2014
    Posts:
    240
    Hi,

    I have migrated to VisualStudio for Mac since it has been released, but still couldn't solve 2 wrong IDE behaviours.
    1. GetComponent auto-complete add () instead of <>(). That is really annoying
    2. Backspace doesn't remove indentation, but that option is active in "Behaviour" tab. Indentation mode sets to "Smart" but in a fact that doesn't matter - in any case backspace removes just a space instead of tabs
    Guys, who work on VM for Mac please make my life easier - tell me, how did you fix it?