Search Unity

VS Community. How to disable automatic closing brace

Discussion in 'External Tools' started by Zwilnik, Dec 3, 2018.

  1. Zwilnik

    Zwilnik

    Joined:
    Jul 22, 2014
    Posts:
    62
    I've just switched to Unity 2018.2 from 2017.4.5.1 and the loss of Mono Develop (which I'd managed to wrangle into working properly) and change to Visual Studio Community for Mac is annoying me a lot, mainly because it's slowing down my workflow by not working properly.

    My main gripe is despite disabling the "Insert matching brace" option in the Beheviour preferences (and restarting many time), it always adds a closing brace whenever I type {
    worse still, it's straight after it.

    It's really annoying me. Is there a way to disable it short of deleting VS Community and just working from BBEdit or something?
     
  2. PixelEnvision

    PixelEnvision

    Joined:
    Feb 7, 2012
    Posts:
    486
  3. Zwilnik

    Zwilnik

    Joined:
    Jul 22, 2014
    Posts:
    62
    Thanks. I gave up on using community and installed VS Code which (while still doing annoying things) can at least be wrangled to work.
     
    PixelEnvision likes this.
  4. Player7

    Player7

    Joined:
    Oct 21, 2015
    Posts:
    1,478
    Yeah I'd like to know aswel.. I also find that behavior absolutely stupid and annoying.
     
unityunity