Search Unity

VS autocomplete does not validate on ";" (1018317))

Discussion in '2018.1 Beta' started by laurentlavigne, Mar 26, 2018.

  1. laurentlavigne

    laurentlavigne

    Joined:
    Aug 16, 2012
    Posts:
    2,015
    you can see it's doing some sort of ghosted rectangle selection of jobcComplete, taunting me that it'll work



    it's on the latest updated of the VS editor
     
  2. Peter77

    Peter77

    Joined:
    Jun 12, 2013
    Posts:
    4,029
    I'm able to reproduce this behavior back to Visual Studio 2012. Why don't use you TAB to auto-complete the soft-selected item instead?

    I imagine there are VS extensions that are more aggressive in terms of auto-complete and perhaps you find one that you like more than the built-in behavior.

    I guess it's unlikely that Microsoft would change this behavior, since it's established for many years. I, for example, don't want VS to auto-complete items non-selected items. If this gets considered to be changed, please make it an option to keep working the old way.

    PS: I guess the actual issue in this case is that VS does not hard-select the "jobComplete" argument in the code-completion list.
     
    Last edited: Mar 26, 2018
    laurentlavigne likes this.
  3. laurentlavigne

    laurentlavigne

    Joined:
    Aug 16, 2012
    Posts:
    2,015
    That's right.
     
  4. mh114

    mh114

    Joined:
    Nov 17, 2013
    Posts:
    281
    For me this issue appears at random times, VS just stops auto-completing normally and gives this half-selected suggestion instead. Very annoying, have to restart VS to fix it. It happens daily, but I'm not sure what triggers it. This issue is in 2017, 2015 and maybe older version too.
     
    laurentlavigne likes this.
  5. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    1,521