Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We are updating our Terms of Service for all Unity subscription plans, effective October 13, 2022, to create a more streamlined, user-friendly set of terms. Please review them here: unity.com/legal/terms-of-service.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

[VR.WaitFo] Slow FPS and Slow Input axis reaction time lag using joystick or pad and VR occulus rift

Discussion in 'AR/VR (XR) Discussion' started by AlanMattano, Apr 12, 2017.

  1. AlanMattano

    AlanMattano

    Joined:
    Aug 22, 2013
    Posts:
    1,469
    Hi there @thep3000 @Ed-unity my joystick has a reaction delay of 1 second. It works properly, If I turn off my VR Oculus rift the joystick and axis input work correctly. In editor and in the game. I'm using Unity 5.5.3
    Looks like there is a relationship with FPS.
    Any idea how to resolve this problem?
     
    Last edited: Apr 13, 2017
  2. AlanMattano

    AlanMattano

    Joined:
    Aug 22, 2013
    Posts:
    1,469
    I jump from 5 fps up to 60, just changing "Shadow Cascades" form non-cascades to 2 cascades.
    @thep3000 @Ed-unity Is there a way to exclude VR.WaitForGPU out from the process?

    I'm too new to programming to do this kind of major clean up. I was looking here:
    SteamVr HTC Vive weird FPS issue

    I wish a code in C# for Oculus that takes out VR.WaitForGPU

    None Cascades 5fps
    upload_2017-4-13_1-5-5.png

    Two Cascades 60fps
    upload_2017-4-13_1-7-48.png
     
    Last edited: Apr 13, 2017
unityunity