Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

VR + HDRP + MSAA = both eyes rending in the left eye

Discussion in 'Graphics Experimental Previews' started by Carwashh, Jun 21, 2019.

  1. Carwashh

    Carwashh

    Joined:
    Jul 28, 2012
    Posts:
    765
    https://gyazo.com/9c257769ac94648d0ddd6829bdec8794

    Trying to get MSAA working with VR and the HDRP, but whenever it's enabled the left eye renders both images and the right eye gets just black. The project is in 2019.1.7, was created using the HDRP template, and we're using the post processing profiles that were already setup in the SampleScene scene.

    The project Stereo Rendering Mode is set to single pass.

    Is it actually possible to have VR+HDRP+MSAA?
     
  2. Benjams

    Benjams

    Unity Technologies

    Joined:
    Oct 27, 2017
    Posts:
    20
    VR+HDRP+MSAA is working correctly in the HDRP package versions 5.7.2 and 5.16.1-preview. So, if you're seeing this in either of those package versions then there is probably an issue with the scene's configuration. Make sure you're using the HDRP-specific 'Volume' components for post-processing (the older post-processing stack v2 package is incompatible with HDRP).

    Do you see the same results in a fresh project with the HDRP template (unaltered)?
    What HDRP package are you using?
    What VR SDK are you testing with?

    If you're sure that your scene is set up properly then I'd suggest you file a bug (with a minimum repro project attached) so we can investigate your issue directly.
     
  3. Eli-Davis

    Eli-Davis

    Joined:
    Jun 2, 2011
    Posts:
    19
    I'm also having the same issue, and I think 150 other people are too judging by the thread here. I've accidentally started a new thread here.

    From the thread:
    In 2019.1.9f1 I created a new project with the HDRP template. It uses HDRP 5.7.2 preview by default. I enabled VR in Player settings and set it to single pass (double-wide). I then went to the HDRenderPipelineAsset and changed Lit Shader Mode to Forward Only, and Multisample Anti-aliasing Quality to 4x. I then checked the box for "MSAA within Forward", and I end up with the issue.

    My HMD is the original Vive (steam VR is not imported into the project, but importing it doesn't change anything).
     
  4. Benjams

    Benjams

    Unity Technologies

    Joined:
    Oct 27, 2017
    Posts:
    20
    Thanks for taking the time to post your detailed repro steps! We were able to reproduce this with your workflow and have opened a ticket to resolve this issue.
     
  5. Benjams

    Benjams

    Unity Technologies

    Joined:
    Oct 27, 2017
    Posts:
    20
    Unfortunately we won't be able to fix this issue in the 2019.1 package. We suggest upgrading to 2019.2 where this issue appears to be resolved.