Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We have updated the language to the Editor Terms based on feedback from our employees and community. Learn more.
    Dismiss Notice

Vive Controller not showing up anymore, tried everything, need help

Discussion in 'AR/VR (XR) Discussion' started by degrees, Jun 15, 2016.

  1. kdragos


    Jun 25, 2016
    I added the update_poses script to the eye camera and it worked! Awesome! Thanks for this fix! :D (Using Unity 5.6.1f1)
  2. dlazardesigns


    Oct 13, 2013
  3. michaelwbyrd


    Jun 19, 2017
    The update_poses script being attached to the eye camera brought back my controllers within the Unity editor when previewing. If I try and publish an .exe, no controllers show within the project. Has anyone had the no controller issue return when publishing their project? (Currently using 5.6.0f3)
  4. KB


    Dec 9, 2012
    I added a 1 second delay before I attempt to use the controllers and now they show up (including in builds). Not an ideal solution but while whoever fixes whatever I can get on with my project.
  5. Justin-Wasilenko


    Mar 10, 2015
    This is a problem for us right now, tracking works but the controller models don't show up in Standalone builds. Using SteamVR 1.2.3, Unity 2017.3.1.p4

    Anyone else with this problem and has found a solution?
  6. Talha171


    Apr 2, 2018
    i used unity 5.6.3 and in stearm vr when me run then the both controller will not showing even i see many videos and follow same instruction help me whats the problem
  7. salvolannister


    Jan 3, 2019
    I still had the problem and the script UpdatePose is now deprecated, for everyone like me stills truggling with this problem here the solution that worked for me taken from here :


    (Skip to step 5 if you already know how to get to the Controller Binding screen from within Unity -- if my fix doesn't work for you, try it again but start at 1 instead. If that doesn't fix it, then you probably have a slightly different issue causing the same problem -- sorry! :( )

    1. Navigate to menu bar and click Window
    2. From the drop-down menu, click on the entry that says SteamVR Input
    3. Near the bottom right of the new modal dialog box that popped up, there should be a button that says "Open binding UI", click that button.

    (Initially when I had the problem, I didn't have anything listed under Current Binding, but I eventually got that corrected -- this step-by-step assumes your have something showing there)

    1. Under Current Binding, there should be a lighter blue content-box with a binding-profile icon, the name of the binding, a button labeled Edit, and maybe even some information that the binding was created by you, when it was last updated, etc. Click the Edit button.

    Here is the meat and potatoes of the fix I figured out (using information Zite posted about what "pose" is all about -- thanks Zite! :) )

    1. Under the controllers, you should see 4 buttons (on my screen it's four. It may vary?). You are looking for the button that says "Edit Action Poses". Click the button that says "Edit Action Poses".

    2. A new box will pop up listing the Poses. They probably all say "Unused" (as they did in my case). Click on the text that says Unused on the line that reads "Left Hand Raw".

    3. Like the previous bindings you set for things like the Grip button, Trigger, Trackpad, etc., a new popup will appear (after clicking the text that reads "Unused" for the proper line). This popup should list Pose and Unused. Click on Pose.

    4. Left Hand Raw should now have the text "Pose" next to it on the same line. Click Close.

    5. At the very bottom of the screen, you will see six buttons. Click on the button that says "Save Personal Binding"

    6. A new popup box will appear asking for the name and description. Fill in the data (if you feel the need to modify any of the existing information), and click the Save button.

    7. You should briefly say the word "Uploading" appear just to the upper left of the left controller in the Controller Binding screen. Wait for that to finish.

    8. Close the Controller Binding screen.

    9. Re-play your Unity project. You should now see your controller appear! You may have to do the pose modification for the right controller too if you did not have the checkbox (under the controllers in the Controller Binding screen) labeled Mirror Mode checked on. But that should fix the problem. Shouldn't be any need to move files or copy anything anywhere, unless you have a situation preventing you from doing what I detailed out.