Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Bug Visual Studio preprocessor directives missing

Discussion in 'Code Editors & IDEs' started by KamilMalochleb, Oct 12, 2022.

  1. KamilMalochleb

    KamilMalochleb

    Joined:
    Mar 25, 2021
    Posts:
    2
    Hello.
    I have very annoying problem with Visual Studio and Unity integration.
    In every other projects there is no problem, because visual studio normally detects preprocessor directives.
    But in one of my projects they are not working. It does not matter if I have defined them in 'player' tab or if they defined in Assembly Definition References. In every other project it works.

    Configuration:
    upload_2022-10-12_10-27-49.png
    upload_2022-10-12_10-27-54.png

    In THIS project Visual Studio:

    upload_2022-10-12_10-28-0.png

    In every single other projects:

    upload_2022-10-12_10-28-36.png

    I'm hopeless because i can't find any solution for this.

    I'm using Unity 2020.3.35f1 and Visual Studio 2019 professional 16.11.19.
     
    Last edited: Oct 12, 2022
  2. MelvMay

    MelvMay

    Unity Technologies

    Joined:
    May 24, 2013
    Posts:
    11,589
    Wrong forum, I'll move your post to here.
     
  3. KamilMalochleb

    KamilMalochleb

    Joined:
    Mar 25, 2021
    Posts:
    2
    Thank you