Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Question Visual Studio Intellisense randomly stopped working, any way to fix?

Discussion in 'Editor & General Support' started by NikGa12345, Dec 3, 2023.

  1. NikGa12345

    NikGa12345

    Joined:
    Oct 24, 2023
    Posts:
    1
    Hi,

    Today in the middle of me writing a script, all of the highlighting disappeared (such as on Transform and SerializeField). I have tried all common fixes such as regenerating project files, reinstalling and intalling the unity module with the VS installer and even reinstalling Visual Studio itself with the unity package, but nothing seems to work. My VS is up to date with the latest version. The very odd thing I noticed is that the intellisense is not working for the project I am currently on but still highlights on scripts from my other older projects. Does anyone know of a possible fix/solution?

    Many Thanks
     
  2. Kurt-Dekker

    Kurt-Dekker

    Joined:
    Mar 16, 2013
    Posts:
    38,321
    This may help you with intellisense and possibly other Visual Studio integration problems:

    Sometimes the fix is as simple as doing Assets -> Open C# Project from Unity. Other times it requires more.

    Other times it requires you also nuke the userprefs and .vsconfig and other crufty low-value high-hassle files that Visual Studio tends to slowly damage over time, then try the above trick.

    Barring all that, move on to other ideas:

    https://forum.unity.com/threads/intellisense-not-working-with-visual-studio-fix.836599/

    Also, try update the package inside of Unity: Window -> Package Manager -> Search for Visual Studio Editor -> Press the Update button

    Depending on flavor and version of Visual Studio, it may also have an installation step that you perform within the actual Visual Studio. This step seems finicky at best and may require multiple openings of VS before it comes up.

    Update: The VSCode extension has been deprecated and abandoned:

    https://forum.unity.com/threads/update-on-the-visual-studio-code-package.1302621/

    Update: the VSCode integration is back... maybe!?

    https://forum.unity.com/threads/microsoft-previews-unity-extension-for-visual-studio-code.1468913/

    There may be a community fork available that is receiving updates.

    https://github.com/Chizaruu/com.tsk.ide.vscode

    Also, this: https://forum.unity.com/threads/no-suggestions-in-vscode.955197/#post-6227874

    Recently (July 2023) I worked on a Windows11 system that required a Microsoft component to be installed from within Visual Studio before it would work properly with all the OTHER software installed under Unity. I have no documentation on that process as I have only seen it once and it surprised me as well.
     
    NikGa12345 likes this.